xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christoph Souris <c...@fargonauten.de>
Subject Re: URIResolver not called
Date Thu, 14 Feb 2008 09:49:08 GMT
Jeremias Maerki wrote:
> On 13.02.2008 14:49:48 Christoph Souris wrote:
>> I have a problem registering a URIResolver instance. According to 
>> the "Embedding" manual I tried to register it at the FOUserAgent 
>> but that did not work (it was not called).

> I use a URIResolver with FOP all the time and I have no problems.

Thats what I expected. It's always only me who has got problems ;(

> In your simple case, the URI resolution may never be invoked if you 
> try with a simple example.

I don't understand that. My example stylesheet contains an xsl:import
statement. The resolver is in fact called if I register it to the
TransformerFactory -- so I asumed that the stylesheet was alright.

I just do not understand why it is NOT called when I register it to the 
FOUserAgent -- which is the usual way to do it, isn't it?

> Furthermore, you should set the URIResolver on the FopFactory so all
> URIs (not only URIs related to a rendering run) are resolved through
> your URIResolver.

I do not want to do that, because I want to share the FopFactory 
instance where each Fop instance is using a different include path.

Besides: Registering the URI resolver at the FopFactory will resolve my 
fonts but (again) not the xsl:import statements.

Regards, Christoph

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message