xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bennen, Jan A." <jaben...@seneca.nl>
Subject RE: FOP 0.93 Euro symbol not displayed
Date Mon, 11 Feb 2008 12:17:12 GMT
Ok, it worked. MS Sans Serif was also ok.
I am using Saxon to create the fo file and I replaced the euro symbol with fo:wrapper font-family="Symbol">&#x20AC;</fo:wrapper>
via the xslt sheet.
That did the job.

Thanks!
 

Met vriendelijke groet, 
Jan Bennen
Support Engineer 
Seneca Helpdesk

Elektronicaweg 31 
2628 XG  Delft,  Nederland 
T   +31 (0)15 - 251 37 77 
F   +31 (0)15 - 251 37 01 
E   support@seneca.nl 
I    www.seneca.nl 
Op dit mailbericht is onze disclaimer van kracht.  


-----Original Message-----
From: Jeremias Maerki [mailto:dev@jeremias-maerki.ch] 
Sent: vrijdag 8 februari 2008 15:24
To: fop-users@xmlgraphics.apache.org
Subject: Re: FOP 0.93 Euro symbol not displayed

Not "MS Sans Serif", "sans-serif" which maps to the built-in base 14
"Helvetica" font. You can also use "Helvetica", of course.

On 08.02.2008 15:14:08 Bennen, Jan A. wrote:
> Which font does have a Euro glyph? MS Sans Serif seems not to have it. Or should I use
another code for the eurosign?
> 
> Met vriendelijke groet, 
> Jan Bennen
> Support Engineer 
> Seneca Helpdesk
> 
> Elektronicaweg 31 
> 2628 XG  Delft,  Nederland 
> T   +31 (0)15 - 251 37 77 
> F   +31 (0)15 - 251 37 01 
> E   support@seneca.nl 
> I    www.seneca.nl 
> Op dit mailbericht is onze disclaimer van kracht.  
> 
> 
> 
> -----Original Message-----
> From: Jeremias Maerki [mailto:dev@jeremias-maerki.ch] 
> Sent: vrijdag 8 februari 2008 14:12
> To: fop-users@xmlgraphics.apache.org
> Subject: Re: FOP 0.93 Euro symbol not displayed
> 
> 
> On 08.02.2008 14:04:54 Bennen, Jan A. wrote:
> > Ok, this worked: the symbol appears, but across the 0 of the following syllable.
Is there a way to add some space between them?
> 
> That's weird. I went looking and found out that the Euro character is
> missing a character width. I'll have to fix that. In that case, just use
> sans-serif instead of Symbol.
> 
> > And is there an easy way to add 
> > <fo:wrapper font-family="Symbol">&#x20AC;</fo:wrapper>
> > to the fo file? My customer does not want to edit the fo file. 
> 
> Two possible solutions:
> - Use a font that has a Euro glyph.
> - Help us implement per-character font-selection which is still missing.
> When that's available you can simply do:
> font-family="MyFont, MyOtherFont, Symbol, ZapfDingbats"
> 
> <snip/>
> 
> 
> 
> Jeremias Maerki


Jeremias Maerki


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message