xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremias Maerki <...@jeremias-maerki.ch>
Subject Re: svg not working on linux
Date Mon, 14 Apr 2008 06:12:25 GMT
In that case you can only try a different version of the Sun JVM or try
alternative approaches for headless servers:
http://xmlgraphics.apache.org/fop/0.95/graphics.html#batik
(Xvfb or PJA)

Maybe someone else has other ideas. I don't.

On 14.04.2008 01:09:30 Roland Neilands wrote:
> j2sdk1.4.2_06
> 
> 
> Jeremias Maerki wrote:
> > Given that it works on some machines but not on others (especially a
> > Linux server) could indicate not a problem in FOP but with the JVM.
> > Please make sure you use a Sun JVM to avoid any problems coming from not
> > fully implemented or buggy class libraries like GNU Classpath (used by
> > GCJ, Kaffee etc.).
> >
> > On 10.04.2008 03:46:28 Roland Neilands wrote:
> >   
> >> Hello foppers,
> >>
> >> We've just put a watermark on our documents & it works fine on two PC's

> >> using FOP 0.20.5, 0.93 & 0.94.
> >>
> >> It's completely ignored on two linux servers (tested with same 3 fop 
> >> versions). The rest of the document renders fine, just no watermark, 
> >> except for 20.5 which fails with an erroneous error about an id already 
> >> existing (yes it only happens with below svg included).
> >>
> >>     <fo:block-container width="25cm" height="18cm" top="0cm" left="0cm" 
> >> position="absolute">
> >>     <fo:block>
> >>       <fo:instream-foreign-object xmlns:svg="http://www.w3.org/2000/svg">
> >>         <svg:svg width="25cm" height="18cm">
> >>             <svg:g transform="rotate(-35)">
> >>               <svg:text x="-200" y="17cm" style="font-family:serif; 
> >> font-size:70pt; font-weight:normal; fill:none; stroke:black; 
> >> stroke-width:1.0; stroke-opacity:0.30; letter-spacing:14pt;">
> >>                 <xsl:value-of 
> >> select="substring-before(Header/Amend_Confirm,':')"/>
> >>               </svg:text>
> >>             </svg:g>
> >>         </svg:svg>
> >>       </fo:instream-foreign-object>
> >>     </fo:block>
> >>   </fo:block-container>
> >>
> >> We've tried changing font, colour & opacity & set the xslt xml 
> >> declaration to standalone. The server already has the headless=true 
> >> option on.
> >>
> >> Can anyone see any problems with this? Otherwise it's gif time.
> >>
> >> Another interesting note is that the svg overlays the region-body text, 
> >> but not the static-content stuff. This is annoying, hence the no-fill.
> >>
> >> -- 
> >> Regards,
> >> Roland 
> >>     
> >
> >
> > Jeremias Maerki


Jeremias Maerki


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message