xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremias Maerki <...@jeremias-maerki.ch>
Subject Re: tables and keeps with 0.95beta
Date Mon, 05 May 2008 07:49:21 GMT
I think this is a bug. I'll look into it. In the meantime, you can work
around the problem by moving the keep-together on the table-cell to the
table-row.

On 05.05.2008 00:14:28 Philipp Wagner wrote:
> Hi,
> 
> I tried FOP 0.95beta together with a table with 
> keep-together.within-page="always" and keep-with-previous="always" 
> attributes, which didn't work in 0.94 at all. While the page breaks are 
> almost correct now, there is a problem with the table headers. I 
> uploaded a sample document at
> http://philipp-wagner.com/temp/20080504-fop/document.fo
> and the PDF output at
> http://philipp-wagner.com/temp/20080504-fop/document.pdf
> 
> If you look on page two you'll see a horizontal line between the first 
> and the second row, which shouldn't be there.
> 
> Apart from that, the keep-with-previous="always" attribute doesn't work, 
> as you can see on the top of the second page, too. The first row on the 
> second page has a keep-with-previous attribute, which should keep it 
> together with the row before, which is not the case here.
> 
> Are this known limitations of FOP or just a small bug? Or are there any 
> workarounds?
> 
> Philipp



Jeremias Maerki


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message