xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Delmelle <andreas.delme...@telenet.be>
Subject Re: Major issue with image loading in FOP 0.95beta
Date Mon, 05 May 2008 16:24:25 GMT
On May 5, 2008, at 18:09, Jean-Fran├žois El Fouly wrote:
>>
>>
>> Two questions, for the moment:
>> Which image format(s) are you using?
> PNG only (but lots of them).

OK, we recently bumped into Mac OS not having a native TIFF codec.  
With a bit of fiddling, one could make the Sun default pure Java  
implementation available as a fallback, but that ran about 30 times  
slower than FOP's own TIFF loader from 0.94.

Maybe a similar thing is happening with PNG, I don't know. I really  
hope Jeremias chimes in later...

For now, you also spoke about the requests "suffocating" the server.  
Do you mean that there are also a lot /more/ requests, or only that  
they take longer to process on the FOP-side? If you also have an  
increase in the total number of requests, this could mean that the  
image-loading framework (unnecessarily?) tries to access the same  
images multiple times, which may already provide a pointer as to  
where to start looking in the code.



Cheers

Andreas
---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message