xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harshini Madurapperuma <harshini.madurapper...@ifs.lk>
Subject RE: charts not rendered on Sun Solaris
Date Wed, 07 May 2008 09:20:03 GMT
Hi

Sorry about it.

I'm using a JfreeChart a third party library to generate charts. Then the outcome to a XSL
will look like this:

<fo:table-cell border-style="none" white-space-collapse="false" vldt-object="FoTableCell"
element-id="old test_18">
    <fo:block vldt-object="MultiBarChart">
        <fo:instream-foreign-object>
          <xsl:copy-of select="chart:multiBarChart(null,        tns:OS_USER,          
         tns:SESSION_ID, '', '',           'Arial', '12' ,0,-12566464, '',               
       'Arial', '18' ,1,-12566464, 'BOTTOM',   'Arial','12','0', 0, 0,                 -43691,
-11184641,      -11141291, -171, -43521, -11141121, -20561,             -8355712, -4194304,
    -16777024, 5.820832666666667,17.0)"/>
        </fo:instream-foreign-object>
    </fo:block>
</fo:table-cell>

And my FOP version is quite old it's 0.20.5. And difficult to upgrade it to a latest version
for the moment.

Regards
Many thanks in Advance
Harshini






-----Original Message-----
From: Jeremias Maerki [mailto:dev@jeremias-maerki.ch]
Sent: Wednesday, May 07, 2008 12:22 PM
To: fop-users@xmlgraphics.apache.org
Subject: Re: charts not rendered on Sun Solaris

As a rule of thumb: Questions which don't require to ask back because there is enough information
to work with are more likely to get answered quickly.

Unfortunately, that's the case here. You didn't:
- say which FOP version you're using (Don't assume everyone remembers from earlier posts which
FOP version you use, or looks it up each time).
- say what kind of "charts" these are. Are they PNGs? TIFFs? SVGs?
Something else?
All that can make a difference. You can save yourself and us time if you put more information
in your questions.

If I had to guess, I'd say you don't have the graphical environment set up properly on the
Solaris machine. Batiks needs that. See:
http://xmlgraphics.apache.org/fop/0.94/graphics.html#batik

On 07.05.2008 05:44:49 Harshini Madurapperuma wrote:
>
> Hi
>
> Can anybody give a suggestion to my problem please  :(
>
> /Harshini
>
> -----Original Message-----
> From: Harshini Madurapperuma [mailto:harshini.madurapperuma@ifs.lk]
> Sent: Tuesday, May 06, 2008 2:24 PM
> To: fop-users@xmlgraphics.apache.org
> Subject: Fo:charts not rendered on Sun Solaris
>
>
> Hi all
>
> I tried to preview a report(with charts) in a Sun Solaris 10
> environment, but the report is not displayed for Preview. But the same
> report is previewed correctly in this same environment after the chart
> is removed from the report.
>
> The same report is previewed (with charts) without problems when it is
> running on a Windows machine.
>
> Is there a problem to render a chart when run on Sun Solaris 10. Or
> should I set some parameters in a special way?
>
>
> Your support is greatly appreciated
> Many thanks in Advance
> Harshini


Jeremias Maerki


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org

------------------------------------------------------------------------------

CONFIDENTIALITY AND DISCLAIMER NOTICE

This e-mail, including any attachments, is confidential and intended only for
the addressee. If you are not the intended recipient, please notify us
immediately and delete this e-mail from your system. Any use or disclosure of
the information contained herein is strictly prohibited.


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message