xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Eberhardt" <robert.eberha...@werum.de>
Subject AW: Problem with EPS Pictures in fop 0.95
Date Mon, 16 Jun 2008 12:55:38 GMT
Hello Jeremias,

First I want to apologize for sending the images off list. 

Second I tried to emebed the file I have sent to you (the second file), but
it failed with the same message (No Image Preloader found). I think the
first file was inserted by the mail server I am using.

I Attached my classpath file, to ask if you can see if I am may using a to
old version of a required library. (smt.jar, mail.jar an so on can be
ignored, I need them the because my application sends the produced pdf by
mail.)

<classpathentry kind="src" path="src"/>
	<classpathentry kind="lib" path="lib/avalon-framework-4.2.0.jar"/>
	<classpathentry kind="lib" path="lib/batik-all-1.6.jar"/>
	<classpathentry kind="lib" path="lib/commons-logging-1.0.4.jar"/>
	<classpathentry kind="lib" path="lib/jdom.jar"/>
	<classpathentry kind="lib" path="lib/ojdbc14.jar"/>
	<classpathentry kind="lib" path="lib/serializer-2.7.0.jar"/>
	<classpathentry kind="lib" path="lib/xalan-2.7.0.jar"/>
	<classpathentry kind="lib" path="lib/xercesImpl-2.7.1.jar"/>
	<classpathentry kind="lib" path="lib/xml-apis-1.3.02.jar"/>
	<classpathentry kind="lib" path="lib/dsn.jar"/>
	<classpathentry kind="lib" path="lib/imap.jar"/>
	<classpathentry kind="lib" path="lib/mail.jar"/>
	<classpathentry kind="lib" path="lib/mailapi.jar"/>
	<classpathentry kind="lib" path="lib/pop3.jar"/>
	<classpathentry kind="lib" path="lib/smtp.jar"/>
	<classpathentry kind="lib" path="lib/activation.jar"/>
	<classpathentry kind="lib" path="lib/log4j-1.2.15.jar"/>
	<classpathentry kind="lib" path="lib/xmlgraphics-commons-1.3.jar"
sourcepath="D:/Dokumente und
Einstellungen/eberhardt/Desktop/xmlgraphics-commons-1.3/src/java">
	<attributes>
		<attribute name="javadoc_location" value="file:/D:/Dokumente
und Einstellungen/eberhardt/Desktop/xmlgraphics-commons-1.3/javadocs/"/>
		</attributes>
	</classpathentry>
	<classpathentry kind="lib" path="lib/fop_095.jar"/>
	<classpathentry kind="var" path="JRE_LIB"/>
	<classpathentry kind="lib" path="lib/commons-io-1.3.1.jar"/>

Maybe you can tell me which jar needs to be updated.


Here you can see the fop code that I use to embed the eps file;

<fo:block  color="white" font-family="ArialRegular" font-size="9pt" >
<fo:external-graphic content-width="95mm" content-height="45mm"
scaling="uniform">
         <xsl:attribute name="padding-left">
		<xsl:value-of select="$padding"></xsl:value-of>
         </xsl:attribute>
         <xsl:attribute name="src">
		<xsl:value-of select="IMAGE/@url"/>
	   </xsl:attribute>
	</fo:external-graphic>
</fo:block>		

Maybe you can send me the code that you have used to test the image.


-----Ursprungliche Nachricht-----
Von: Jeremias Maerki [mailto:dev@jeremias-maerki.ch] 
Gesendet: Montag, 16. Juni 2008 14:34
An: fop-users@xmlgraphics.apache.org
Betreff: Re: Problem with EPS Pictures in fop 0.95

Robert sent me two files off-list. The first (size 65KB) is something I
don't recognize. It's definitely not an EPS file (neither binary not
ASCII). GhostScript cannot display it either. ImageMagick seems to think
of it as an EPS file but then fails to process it. The second (size
4.1MB) is an ASCII-mode EPS containing a large bitmap. That is displayed
by GhostScript and properly handled by FOP 0.95beta.

I assume you get the error for the first file but you opened the second
in GhostScript. You probably chose the wrong file format for saving the
image in Photoshop or something like that. I mention Photoshop as that
string can be found in both files.

On 16.06.2008 13:26:50 Robert Eberhardt wrote:
> Hello,
>  
>  I have a problem with a single eps picture.
>  
> I try to emdeb the image as an <fo:external-graphic> in a Postscript File.
> I get the following Error Message
>  
>  
> 2008-06-16 13:20:13,343 ERROR [main] org.apache.fop.fo.FONode: Image not
> available: No ImagePreloader found for
>
W:\.eclipse_Head\Mailing\res\images\tmp\tmp2\..\..\medias\0000\00\13\33\1258
> 418.eps
>  
> The picture is in the given directory and other eps files are loaded as
> well. Loading the eps picture with gostview also works fine.
>  
>  
> Maybe someone can help me to find the right image preloader for that file.
>  
>                                                
>                                    Kind regards Robert Eberhardt
> --




Jeremias Maerki


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message