xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From _zachary_ <zda...@mac.com>
Subject Re: FOP 0.94 AND 0.95b
Date Thu, 12 Jun 2008 20:50:33 GMT

This is what occurs when i try to build using ant v1.7

=====================================
[root fop95]# ant
/usr/bin/build-classpath: error: Could not find xml-commons-apis Java
extension for this JVM
/usr/bin/build-classpath: error: Some specified jars were not found
Buildfile: build.xml

init-avail:
     [echo] ------------------- Apache FOP 0.95beta [1999-2008]
----------------
     [echo] See build.properties and build-local.properties for additional
build settings
     [echo] Apache Ant version 1.7.0 compiled on June 5 2008
     [echo] VM: 4.1.1 20070105 (Red Hat 4.1.1-51), Free Software Foundation,
Inc.
     [echo] JAVA_HOME: ${env.JAVA_HOME}
     [echo] JAI Support NOT Present
     [echo] JCE Support PRESENT
     [echo] JUnit Support NOT Present - Committers are required to have
JUnit working
     [echo] XMLUnit Support NOT Present - you can get it from
http://xmlunit.sourceforge.net

init:

codegen:
     [echo] Generating the java files from xml resources
     [xslt] java.lang.ClassNotFoundException:
org.apache.tools.ant.taskdefs.optional.TraXLiaison not found in
gnu.gcj.runtime.SystemClassLoader{urls=[file:/usr/share/java/ant.jar,file:/usr/share/java/ant-launcher.jar,file:/usr/share/java/jaxp_parser_impl.jar,file:/usr/lib/jvm/java/lib/tools.jar],
parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
     [xslt]    at java.net.URLClassLoader.findClass(libgcj.so.7)
     [xslt]    at java.lang.ClassLoader.loadClass(libgcj.so.7)
     [xslt]    at java.lang.ClassLoader.loadClass(libgcj.so.7)
     [xslt]    at java.lang.Class.forName(libgcj.so.7)
     [xslt]    at java.lang.Class.forName(libgcj.so.7)
     [xslt]    at
org.apache.tools.ant.taskdefs.XSLTProcess.loadClass(XSLTProcess.java:548)
     [xslt]    at
org.apache.tools.ant.taskdefs.XSLTProcess.resolveProcessor(XSLTProcess.java:533)
     [xslt]    at
org.apache.tools.ant.taskdefs.XSLTProcess.getLiaison(XSLTProcess.java:789)
     [xslt]    at
org.apache.tools.ant.taskdefs.XSLTProcess.execute(XSLTProcess.java:300)
     [xslt]    at
org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:294)
     [xslt]    at java.lang.reflect.Method.invoke(libgcj.so.7)
     [xslt]    at
org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
     [xslt]    at org.apache.tools.ant.Task.perform(Task.java:364)
     [xslt]    at org.apache.tools.ant.Target.execute(Target.java:358)
     [xslt]    at org.apache.tools.ant.Target.performTasks(Target.java:390)
     [xslt]    at
org.apache.tools.ant.Project.executeSortedTargets(Project.java:1330)
     [xslt]    at
org.apache.tools.ant.Project.executeTarget(Project.java:1299)
     [xslt]    at
org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:48)
     [xslt]    at
org.apache.tools.ant.Project.executeTargets(Project.java:1183)
     [xslt]    at org.apache.tools.ant.Main.runBuild(Main.java:702)
     [xslt]    at org.apache.tools.ant.Main.startAnt(Main.java:200)
     [xslt]    at
org.apache.tools.ant.launch.Launcher.run(Launcher.java:268)
     [xslt]    at
org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)

BUILD FAILED
/home/fop95/build.xml:297: java.lang.ClassNotFoundException:
org.apache.tools.ant.taskdefs.optional.TraXLiaison not found in
gnu.gcj.runtime.SystemClassLoader{urls=[file:/usr/share/java/ant.jar,file:/usr/share/java/ant-launcher.jar,file:/usr/share/java/jaxp_parser_impl.jar,file:/usr/lib/jvm/java/lib/tools.jar],
parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}



_zachary_ wrote:
> 
> Sounds good, I'll just wait, I was having trouble building from src.  Do
> you have an estimated time of when that will be released?
> 
> 
> 
> Andreas Delmelle-2 wrote:
>> 
>> On Jun 5, 2008, at 17:31, _zachary_ wrote:
>> 
>>> Sweet thank you, so can i download the binary from somewhere or do  
>>> i have to
>>> do a checkout from the svn repo?
>> 
>> If you want to try it out immediately, you'll need to check out from  
>> the svn repo, and build the binary yourself (proverbial piece-of-cake  
>> if you already have Ant installed).
>> 
>> Otherwise, you'll need to wait some for 0.95 final (to be released soon)
>> 
>> 
>> Cheers
>> 
>> Andreas
>> 
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
>> For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org
>> 
>> 
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/FOP-0.94-AND-0.95b-tp17630414p17809416.html
Sent from the FOP - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message