xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Wechner <michael.wech...@wyona.com>
Subject Re: java.lang.NoClassDefFoundError: com/sun/jimi/core/Jimi
Date Fri, 06 Jun 2008 07:56:34 GMT
Chris Bowditch wrote:

> Jeremias Maerki wrote:
>
> <snip/>
>
>>
>> So if FOP does want Jimi, putting it in the classpath hopefully fixes
>> the problem. But still, I'm at a loss to explain why the JimiImage class
>> is triggered in the first place.
>
>
> The Original Post said FOP had been built via Maven. So could it be 
> that the FOP Maven POM has an incorrect dependency on Jimi?


I didn't see any for FOP-0.93

The code of FOP-0.93 itself is calling Jimi during runtime via dynamic 
class loading, and hence one will not notice the missing Jimi lib until 
actually running it.

But as said, after cleaning it's working now fine (which is strange 
though ;-)

Cheers

Michael

>
> <snip/>
>
> Chris
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
> For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org
>


-- 
Michael Wechner
Wyona      -   Open Source Content Management - Yanel, Yulup
http://www.wyona.com
michael.wechner@wyona.com, michi@apache.org
+41 44 272 91 61


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message