xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From craigb321 <craigbudd...@hotmail.com>
Subject Type 1 Custom Fonts problems in Postscript
Date Thu, 12 Mar 2009 14:47:24 GMT

 Hi,
I am trying to produce PDF and postscript output from XSL:FO using FOP 0.95
- and I need to include some custom fonts.
 The custom fonts are true type currently - and I guessed they needed
converting to Type1 before they would work with PostScript.> I converted
them to .PFA / .PFB + .AFM files using ttf2pt1, and updated the FOP config
file for both PDF and Postscript renderers sections to look in the directory
where these live.

 The PDF picks up the new fonts and they work fine ... (so I am guessing the
conversion worked ok).
 The PostScript runs through FOP with no errors, but the output of the new
fonts is all spaces or characters like ! ( " ) .
 I am wondering if I need to run PFMReader to try and generate the XML
metrics file ?? , but I don't have PFM files ...
 Also, when I have tried to execute PFMReader through MS Dos, it has
returned a ClassNotFoundException.
 I would be really grateful for any thoughts !!
Thanks,
Craig
-- 
View this message in context: http://www.nabble.com/Type-1-Custom-Fonts-problems-in-Postscript-tp22477721p22477721.html
Sent from the FOP - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message