xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vincent Hennebert <vhenneb...@gmail.com>
Subject Re: No ImagePreloader found for *.svg
Date Wed, 04 Mar 2009 11:03:38 GMT
Hi Francesc,

Francesc Alted wrote:
<snip/>
>> Anyway, something else to check:
>>> 3-mar-09 8:26:09
>>> org.apache.fop.fo.properties.CommonBorderPaddingBackground <init>
>>> SEVERE: Background image not available:
>>> http://docbook.sourceforge.net/release/images/draft.png
>> Does this PNG fail because you are not connected to the internet? Is  
>> the URL incorrect, or could this be related to the current issue?
> 
> I don't know, but I have access to this file for sure:
> 
> wget http://docbook.sourceforge.net/release/images/draft.png
> --2009-03-04 09:37:00--  http://docbook.sourceforge.net/release/images/draft.png
> S'està resolent docbook.sourceforge.net... 216.34.181.96
> S'està connectant a docbook.sourceforge.net|216.34.181.96|:80...connectat.
> HTTP: s'ha enviat la petició, s'està esperant una resposta...200 OK
> Mida: 17454 (17K) [image/png]
> S'està desant a: «draft.png.1»
> 
> 100%[======================================>] 17.454       102K/s   en 0,2s
> 
> 2009-03-04 09:37:01 (102 KB/s) - s'ha desat «draft.png» [17454/17454]
>  
>> Using the sample tarball you provided, I cannot immediately reproduce  
>> any of the error messages, although I do get a complaint from  
>> PreloaderSVG about an "invalid byte 1 of a 1-byte UTF-8 sequence". The  
>> SVG is included in the end-result, nonetheless.
> 
> Yeah.  As I have said, fop seems to work perfectly in my old laptop too :-\
> I don't know, but that could be a 64-bit problem?  Is anybody running
> a 64-bit OS that can give the tarball a try?

I can render your document without any problem on my 64-bit Ubuntu, both
with FOP 0.95 and FOP Trunk.

You said you installed FOP from the OpenSUSE repository, so I’d suspect
there is a packaging problem there. Is XML Graphics a separate package
that FOP depends on? What version is it?
Can you try again with a version of FOP directly downloaded from our
website:
http://xmlgraphics.apache.org/fop/download.html#binary

If that works with that version then this indeed is an OpenSUSE
packaging problem. You may then want to notify the maintainers of your
problem.

HTH,
Vincent

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message