xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francesc Alted <fal...@pytables.org>
Subject Re: AW: No ImagePreloader found for *.svg
Date Tue, 03 Mar 2009 18:20:08 GMT
Jeremias Maerki <dev <at> jeremias-maerki.ch> writes:

> 
> Probably a class-loader issue. I'd avoid using the CLASSPATH environment
> variable wherever possible (which is pretty much always). Please make
> sure fop.jar, xmlgraphics-commons.jar and batik.jar are specified at the
> same level in the class-loader hierarchy, i.e. in the same -cp statement
> when starting the JVM, in the same WAR file or whatever you're doing to
> run FOP.

Sorry, but I'm a bit naive with java environments.  I see this file:

-rw-r--r-- 1 root root 3318083 31 jul  2008 /usr/share/fop/lib/batik-all-1.7.jar

which is large enough to suppose that the entire batik is there, correct?
If this is true, I suppose that the next lines in the main fop shell script:

# add in the dependency .jar files, which reside in $FOP_HOME/lib
OLD_IFS=$IFS
IFS="
"
DIRLIBS=${FOP_HOME}/lib/*.jar
for i in ${DIRLIBS}
do
    # if the directory is empty, then it will return the input string
    # this is stupid, so case for it
    if [ "$i" != "${DIRLIBS}" ] ; then
      if [ -z "$LOCALCLASSPATH" ] ; then
        LOCALCLASSPATH=$i
      else
        LOCALCLASSPATH="$i"${pathSepChar}$LOCALCLASSPATH
      fi
    fi
done

should be enough to include batik in the class-loader hierarchy (I've
checked that $FOP_HOME is /usr/share/fop).  Or am I missing something?

Thanks,

Francesc



---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message