xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adrian Wiesmann <awiesm...@somap.org>
Subject Empty PDF on Windows
Date Fri, 15 May 2009 17:14:01 GMT
Hello everybody

I am having a strange problem with FOP and would like to hear your
comments. I am having a UI engine which renders HTML, Swing and now also
PDF via FOP. On some systems I get content in the PDF (text, image,
table), on other systems the PDF have the correct number of pages, but
the pages are empty (white). When opening the empty PDF, I can see the
header information looking all right (and I can see the creator tag
correctly in the PDF). 

The empty PDF are empty not only in Adobe Acrobat Professional, but also
in Reader, KPDF and other readers.

All systems have the same code. Used libraries seem to be the same on all
systems (Ant script compiles code and generates WAR).

Systems where everything works:

- Linux, Eclipse, SUN JDE 1.6, Tomcat 6.
- Windows Vista, Eclipse, SUN JDE 1.6, Tomcat 6.

Systems where it does not work:

- Linux, Tomcat 5, IBM JVM.
- Windows Vista, Tomcat 6, SUN JRE.

The obvious difference is that on the systems where the PDFs are generated
correctly the application is run from within Eclipse.

I get no error or obvious debug message on any system whatsoever.

Does anybody have an idea where I could look at or what to test to find
this bug or misconfiguration? Could it be a memory problem, something
missing..?

I found some threads discussing empty PDF but no solutions to my problem
so far.

Thanks for your help in advance.

Cheers,
Adrian

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message