xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adrian Wiesmann <awiesm...@somap.org>
Subject Re: Empty PDF (on Windows)
Date Tue, 19 May 2009 19:14:37 GMT
Sam,

Thanks for your help.

> I had a very similar problem to this.  Just before I transformed the fo
> to pdf I needed to set the system property to headless.  This would be
> done like:
> System.setProperty("java.awt.headless", "true");  Though I'd recommend
> storing a string of the original value and resetting it to this value
> after you trasformation.

I already do this when starting up the application. At least in the web
version of the tool.

Unfortunately your hint did not result in a solution. I tried as you said.
With no luck. I then added a transformer errorlistener to log any errors
which might have been undetected otherwise. But the only failure I get is
about a table not being 100% or something.

The situation is really weird: 

- Runnin on Linux using a SUN JDK running within Eclipse... 
- ...as well as deployed to a Tomcat 6 as a war file works.

- Running on Windows deployed as a WAR file to Tomcat 6 running in a JRE
does *not* work.

- Running on Linux using IBM JRE deployed to Tomcat 5 as a WAR file does
*not* work.

- Running on Windows within Eclipse with a JDK and within Tomcat 6
seems to work. At least as far as I can remember (have no access to that
system right now).

And I always tried Firefox as well as IE. Just to make sure this is not a
cache or mime issue.

I start to believe that this is a JRE vs JDK issue? I remember from my
JasperReports days, that there was an issue on JRE systems and that I had
to add a "compiler" JAR on those systems. Could this be the same here?

Cheers,
Adrian

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message