xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Forrester <rc...@us.ibm.com>
Subject Re: Getting PDF output to display Russian characters
Date Wed, 06 May 2009 13:04:47 GMT
Vincent,

Thanks for the tip.. I will also give this a try.

Thank You!

Richard C. Forrester IV
IBM Global Announcements & Sales Manual
Technical Lead/Analyst/Developer
Email : rcfiv@us.ibm.com
Phone : (303) 773-5288
T/L : 8-656-5288
Mobile: (303) 596-5572
Home Page:  http://gpt.boulder.ibm.com/gpa/welcome.do


|------------>
| From:      |
|------------>
  >--------------------------------------------------------------------------------------------------------------------------------------------------|
  |Vincent Hennebert <vhennebert@gmail.com>                                        
                                                                 |
  >--------------------------------------------------------------------------------------------------------------------------------------------------|
|------------>
| To:        |
|------------>
  >--------------------------------------------------------------------------------------------------------------------------------------------------|
  |fop-users@xmlgraphics.apache.org                                                      
                                                           |
  >--------------------------------------------------------------------------------------------------------------------------------------------------|
|------------>
| Date:      |
|------------>
  >--------------------------------------------------------------------------------------------------------------------------------------------------|
  |05/06/2009 04:16 AM                                                                   
                                                           |
  >--------------------------------------------------------------------------------------------------------------------------------------------------|
|------------>
| Subject:   |
|------------>
  >--------------------------------------------------------------------------------------------------------------------------------------------------|
  |Re: Getting PDF output to display Russian characters                                  
                                                           |
  >--------------------------------------------------------------------------------------------------------------------------------------------------|





Hi Richard,

In addition to what Andreas said, you must have had some warning from
FOP telling you that it couldn’t find your Russian font, and that it
switched to a default one that doesn’t contain the needed glyphs. Or
maybe you didn’t specify the font-family property in the FO file? You
have to set it to the name you gave in the config file, here ‘lucon’.
Since this is an inheritable property, setting it on the fo:root element
shoud do the job.

Also, starting from FOP 0.95 you don’t need to manually generate the XML
metrics any more. You can reduce your configuration to the following:
    <font kerning="yes" embed-url="lucon.ttf">
      <font-triplet name="lucon" style="normal" weight="normal"/>
    </font>

HTH,
Vincent


Andreas Delmelle wrote:
> On 05 May 2009, at 19:31, Richard Forrester wrote:
>
> Hi
>> I have files that I produce that are in other languages. However, when
>> I try to publish in Russian, I get # sign instead of the Russian
>> character. Is there an easy way to configure FOP so that it will
>> produce those Russian characters. I can create text files and html
>> files that display the characters, so they must be installed on my
>> machine and the server. Here's my config file, could it be something
>> in there?
>>
> First thing to check (no offense): is the configuration actually used? I
> mean: just want to make sure that no one expects the config file to be
> picked up automatically. The fop.xconf in the distribution is NOT used,
> unless you tell FOP to use it.
> (see:
>
http://xmlgraphics.apache.org/fop/0.95/configuration.html#general-available
)
>
>
> If you're sure FOP is using the config-file, then try running with debug
> output. (Make sure the log implementation is set to debug-level; simply
> using the '-d' option is not enough)
> FOP is known to choke on some TTF variants. Just because you have a font
> available does not guarantee that FOP can handle it. Try locating the
> physical font-file, and generate the metrics from it, manually. If that
> doesn't work, that explains why the auto-detection code skips processing
> the font.
>
>
> HTH!
>
> Andreas
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
> For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message