xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Delmelle <andreas.delme...@telenet.be>
Subject Re: Arial True Type becomes italic in AWT
Date Tue, 14 Jul 2009 15:00:38 GMT
On 14 Jul 2009, at 13:12, Vincent Hennebert wrote:

Hi Kuno, Vincent,

> Kuno sent me his FO file off-list for confidentiality reasons. The
> interesting part is the fo:flow element:
>    <fo:flow flow-name="xsl-region-body" font-style="normal"
>      font-family="Arial,Helvetica" font-size="8pt">
> font-family is overridden nowhere else.
>
> On my Linux system the file renders fine, using the Helvetica font  
> since
> I don’t have Arial installed.

I tried rendering a fairly simple document with the same font-family  
and -style specification to AWT on Mac OS X, without luck. I have  
Arial installed and it seems to be properly registered, and cannot  
reproduce the issue. Ultimately also a *nix based platform...
It would be interesting to know if the issue persists if you use a  
different Java vendor or version. That could rule out or confirm  
whether it's a quirk in the AWT-font implementation (which would not  
be under our control; fingers crossed :-))

Enabling DEBUG or TRACE output will show you more in detail what  
happens when the fonts are registered.
Via the command-line, you can do so by setting the following system  
properties

- 
Dorg 
.apache.commons.logging.Log=org.apache.commons.logging.impl.SimpleLog
-Dorg.apache.commons.logging.simplelog.defaultlog=debug


Regards

Andreas


Andreas Delmelle
e-mail: andreas.delmelle.AT.telenet.be
Skype: adlm0608
Jabber: mandreas@jabber.org


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message