xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mohammed Farouk <hin_tcho_...@yahoo.com>
Subject Re: newFOP taking very long time
Date Wed, 12 Aug 2009 21:08:38 GMT
Hi dschu012

I'm using the command line for running fop, I'm also auto detecting fonts, and I believes
that it can cause this much of time.
but I have checked it and it was around 4 secs (first time) and around one second the next
times.

try to register only the fonts that you need, and try again

 
Good Luck
Mohammed



________________________________
From: dschu012 <dschu012@gmail.com>
To: fop-users@xmlgraphics.apache.org
Sent: Wednesday, August 12, 2009 10:22:20 PM
Subject: newFOP taking very long time


Hi,

I am using FOP 0.95 and am experience issues with PDF generation taking
outrageous amounts of time. After some investigation I realized that during
my first time the method is called after starting my server that it takes
around 20 seconds to execute the following line of code.
fopFactory.newFop(MimeConstants.MIME_PDF, foUserAgent, out)
Every subsequent call to the method it will still take somewhere around 2
seconds to create a new FOP. Could the amount of time it is taking have to
deal with me having FOP auto-detect the fonts? I have look and haven't seen
anyone else having similar issues so I figure it must be something I am
doing causing this.

Thanks,
dschu012
-- 
View this message in context: http://www.nabble.com/newFOP-taking-very-long-time-tp24943000p24943000.html
Sent from the FOP - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


      
Mime
View raw message