xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Bowditch <bowditch_ch...@hotmail.com>
Subject Re: [!! SPAM] Re: Re: font configuration
Date Tue, 18 Aug 2009 07:54:01 GMT
Ming Yu wrote:

Hi,

> I did try this. But I'm not sure how to use it in the font= representation. This is what
I have in my fop.xconf file:

We did discuss this before. Use the following to reference Arial Bold

<quote who="Ming Yu">
Even when I use individual tag as font-size="16pt" font-weight="bold" 
font-family="Arial", FO engine also gives this warning:
 > WARNING: Font 'Arial,normal,700' not found. Substituting with 
'any,normal,700'.
</quote>

> 
>       <font kerning="yes" embed-url="file:///C:/WINDOWS/Fonts/arial.ttf">
>           <font-triplet name="Arial" style="normal" weight="normal"/>
>           <font-triplet name="ArialMT" style="normal" weight="normal"/>
>         </font>
> 
>         <font kerning="yes" embed-url="file:///C:/WINDOWS/Fonts/arialbd.ttf">
>           <font-triplet name="Arial" style="normal" weight="bold"/>
>           <font-triplet name="ArialMT" style="normal" weight="bold"/>
>         </font>
> 
> Thanks!
> 
> Ming

Thanks,

Chris

> 
> 
> 
> ----- Original Message ----
> From: Chris Bowditch <bowditch_chris@hotmail.com>
> To: fop-users@xmlgraphics.apache.org
> Sent: Monday, August 17, 2009 11:37:14 AM
> Subject: Re: [!! SPAM]  Re: font configuration
> 
> Ming Yu wrote:
> 
>>Thanks for the reply. Yes, I just configured my fop.xconf file by removing the metrics-url
attribute and the Arial font works. 
>>But I still cannot make the "bold" work. Whenever I put bold into the font=, either
warning or SEVERE message will appear.
> 
> 
> Arial and Arial Bold are separate Fonts. This isn't clear to Font newbies because of
MS Word's ability to mimic Bold and Italic Font variants from the regular Font. So if you
need Bold and Italic variants of Arial you must register them separately within fop.xconf,
e.g.
> 
> <font kerning="yes"
>        embed-url="file:///C:/windows/fonts/arialbd.ttf">
>       <font-triplet name="Arial" style="normal" weight="bold"/>
>    </font>
> 
>>Do you have any idea how I can configure to make the bold (or the font-weight) work
in the shorthand representation?
>>
>>Thanks a lot!
>>
>>Ming
>>
> 
> 
> HTH,
> 
> Chris
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
> For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org
> 
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam protection around 
> http://mail.yahoo.com 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
> For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org
> 
> 
> 




---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message