xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vincent Hennebert <vhenneb...@gmail.com>
Subject Re: provisional-distance-between-starts with a percentage
Date Mon, 14 Sep 2009 09:37:47 GMT
Hi Eric,

Looks like a bug indeed. Could you please file a bug report on FOP's
Bugzilla [1], attaching a simple FO file showing the issue? That will
help us keep track of the problem.

Thanks,
Vincent

[1] https://issues.apache.org/bugzilla/enter_bug.cgi?product=Fop


Amick, Eric wrote:
> The spec suggests that percentages are legal in
> provisional-distance-between-starts, but FOP apparently doesn't like it.
> 
>  
> 
> Try the following FO fragment:
> 
>  
> 
>                 <block-container width="100%">
> 
>                         <block>
> 
>                             <list-block
> provisional-distance-between-starts="50%">
> 
>                                 <list-item>
> 
>                                     <list-item-label
> end-indent="label-end()">
> 
>                                         <block>foo</block>
> 
>                                     </list-item-label>
> 
>                                     <list-item-body
> start-indent="body-start()">
> 
>                                         <block>bar</block>
> 
>                                     </list-item-body>
> 
>                                 </list-item>
> 
>                             </list-block>
> 
>                        </block>
> 
>                   </block-container>
> 
>  
> 
> When I try that, the list-item-body winds up on top of the
> list-item-label, as if body-start() returns 0. I'm probably missing
> something, but I'm not sure what.
> 
>  
> 
> Eric Amick
> 
> LCS
> 
> Office of the Clerk
> 
>  
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message