xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Glen Mazza <glen.ma...@gmail.com>
Subject Re: Problem using attributes with <xsl:value-of select=""/>
Date Wed, 25 Nov 2009 00:15:07 GMT


J.Pietschmann wrote:
> 
>>
>>Hmm, Transformers can't be reused, perhaps you should get a new
>>instance here?
>>
> 

Oh, I did not know that.  Thanks for the info.


J.Pietschmann wrote:
> 
>>Another possible problem:
>> atts.addAttribute("", "", "reportId", "", "123");
> 
>>The method declaration is:
>>  addAttribute(String uri, String localName, String qName, String type,
>>    String value)
> 
>>You are setting the local name to "", which may  cause hiccups.
>>Try any of the following:
>>  atts.addAttribute("", "reportId", "reportId", "", "123");
>>  atts.addAttribute(null, "reportId", "reportId", "", "123");
>>(Actually, I have no idea which one should work, may even be
>>implementation dependent).
> 

Yes, that was the problem!   Either alternative you have above fixed the
problem for me.

Thanks Joerg!

Glen
-- 
View this message in context: http://old.nabble.com/Problem-using-attributes-with-%3Cxsl%3Avalue-of-select%3D%22%22-%3E-tp26451537p26505563.html
Sent from the FOP - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message