xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Isabel Hofherr <Isabel.Hofh...@kofax.com>
Subject embedding fonts fails for Cyrillic
Date Thu, 19 Nov 2009 10:04:06 GMT
Hi,

we want to generate PDFs with Docbook to get different language output (e.g. Cyrillic, Japanese
and simplified Chinese).
First we tried to generate Cyrillic output by doing the following:

Prerequisites:

·         FOP Version 0.94

·         updated XSL styles to use the font as body font

Steps:

1.       Installing a True Type Font for Cyrillic (ER Arial KOI-8) in the fonts directory

2.       Added the font to the fop.xconf:

     <font metrics-url=" file:///Q:/fop/fonts/ERARKOI8.xml"  kerning="yes" embed-url="file:///Q:/fop/fonts/ERARKOI8.TTF">

           <font-triplet name="ER Arial KOI-8" style="normal" weight="normal"/>

       </font>

Note from your Help:

Beginning with version 0.94 you can skip the generation of font metric files and remove the
"font-metrics" attribute(?) in the font configuration. The font metrics files are, for the
moment, still required if you use a TrueType Collection (*.ttc) and in that case you need
to regenerate the font metrics file.

-->We only use a .ttf - but it didn't worked without a font-metrics attribute. The body
text always was displayed with pound signs(#).


3.       So I decide to generate an appropriate font metrics file for it by entering the command
line options:

java -cp build\fop.jar; -jar lib\avalon-framework-4.2.0.jar;lib\commons-logging-1.0.4.jar;lib\commons-io-1.3.1.jar

org.apache.fop.fonts.apps.TTFReader

Q:\fop\fonts\ERARKOI8.TTF ERARKOI8.XML



But although I've added the correct version suffix to the jar files I got error messages:

                Unable to access jarfile lib\avalon-framework-4.2.0.jar;lib\commons-logging-1.0.4.jar;lib\commons-io-1.3.1.jar

When entering only the following:

java -cp build\fop.jar; -jar lib\avalon-framework-4.2.0.jar

then this error message was displayed:

Failed to load Main-Class manifest attribute from lib\avalon-framework-4.2.0.jar




Is it possible that this True Type Font doesn't contain the so-called Unicode "cmap" table?
How can I check this?
I'm not  so familiar with Java so please give me a hint how to solve this problems.

Thanks,
Isabel











Isabel Hofherr
Tech Comm Spc.
Kofax Development GmbH

Freiburger Strasse 6
79199 Kirchzarten
Germany

Tel: +49 (0) 766 197 97 12
Fax: +49 (0) 766 1979729
Isabel.Hofherr@kofax.com


________________________________

This communication is only for the use of the intended recipient. It may contain confidential
or proprietary information. If you are not the intended recipient or have received this communication
in error, please notify the sender via phone and destroy this communication immediately.
Kofax Development GmbH
Sitz der Gesellschaft: Kirchzarten
Registergericht: Amtsgericht Freiburg i.Br.
Registernummer: HRB 7007
Geschäftsführer: Stefan Gaiser und Bradford Weller


Mime
View raw message