xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ari Army <armyofda12mnk...@gmail.com>
Subject Using/Embedding fonts with FOP
Date Fri, 08 Jan 2010 19:29:14 GMT
Hey all,
I'm a lil' at a loss on how to get fonts working with fop even though
there seems to be good documentation on it
(
http://xmlgraphics.apache.org/fop/0.95/fonts.html
http://xmlgraphics.apache.org/fop/0.95/configuration.html
http://www.sagehill.net/docbookxsl/AddFont.html
)...
I remember a few years ago I got fonts to work somehow, but I think in
versions >.94, its supposed to be easier so you dont have to create
font-metric files or stuff like that based on documentation I'm
reading (btw using trunk version I checked out today)...
So this kinda explains that: "
Prior to FOP version 0.94, it was always necessary to create an XML
font metrics file if you wanted to add a custom font. This
unconvenient step has been removed and in addition to that, FOP
supports auto-registration of fonts, i.e. FOP can find fonts installed
in your operating system or can scan user-specified directories for
fonts. Font registration via XML font metrics file is still supported
and is still necessary if you want to use a TrueType Collection
"

I am doing something simple like only time I reference a font i do
like this: <fo:inline font-family="Arial Black">blah</fo:inline>, and
it is not working.
Getting this output:

$fop -c "C:/dev/fop/config/user-config.xml" test.fo test.pdf
Jan 8, 2010 2:08:52 PM org.apache.fop.events.LoggingEventListener processEvent
WARNING: Font "Symbol,normal,700" not found. Substituting with
"Symbol,normal,400".
Jan 8, 2010 2:08:52 PM org.apache.fop.events.LoggingEventListener processEvent
WARNING: Font "ZapfDingbats,normal,700" not found. Substituting with
"ZapfDingbats,normal,400".
Jan 8, 2010 2:08:52 PM org.apache.fop.events.LoggingEventListener processEvent
WARNING: Font "Arial Black,normal,400" not found. Substituting with
"any,normal,400".

Thought since I had Arial Black on my computer that it wouldn't
complain when making the pdf and would auto-register.

If i have to make a custom user-config.xml to pass to command line -c
parameter, what should it look like?
something like this?...

<fop version="1.0">
  <renderer mime="application/pdf">
    <fonts>
      <!-- register all the fonts found in a directory, this step may
not be necessary if auto-detect tag basically does this automatically,
also tried this file without below, still doesnt work -->
      <directory>C:\WINDOWS\Fonts</directory>

      <!-- automatically detect operating system installed fonts -->
      <auto-detect/>
    </fonts>
  </renderer>
</fop>

and then ran:
$fop -c "C:/dev/fop/config/user-config.xml" test.fo test.pdf

Above doesn't work, thought it would find and embed the font i want to
use automatically with that new "auto-detect" xml tag.

Any guidance is appreciated on clarification on embedding fonts (with trunk),
Thanks,
Ari

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message