xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pascal Sancho <pascal.san...@takoma.fr>
Subject Re: SVG as background to page in 0.95
Date Thu, 25 Mar 2010 14:11:13 GMT
Mario,

can you try either:
background-image="c:\path\to\file.svg"
or:
background-image="url(file:///c:/path/to/file.svg)"

both should work.

Pascal

Mario Madunic a écrit :
> Pascal,
>
> I declare the image via a variable like this,
>
> <xsl:variable name="g_NumericIndexPage" select="concat('file:///', $cl_WorkDir, '/graphics/numericIndexPage.svg')"
/>
> Which works out to file:///D:/workDirs/publish/graphics/numericIndexPage.svg. So I've
tested all the following as the value of the variable
>
> file:///D:/workDirs/publish/graphics/numericIndexPage.svg
> file://D:/workDirs/publish/graphics/numericIndexPage.svg
> file:/D:/workDirs/publish/graphics/numericIndexPage.svg
> graphics/numericIndexPage.svg
> ../graphics/numericIndexPage.svg
> ../../graphics/numericIndexPage.svg
> ../../../graphics/numericIndexPage.svg
>
> All the above failed to load the svg using 0.95
>
> file:///D:/workDirs/publish/graphics/numericIndexPage.svg works 0.94
> file://D:/workDirs/publish/graphics/numericIndexPage.svg failed 0.94 as expected
> file:/D:/workDirs/publish/graphics/numericIndexPage.svg works 0.94
> graphics/numericIndexPage.svg works
> ../graphics/numericIndexPage.svg failed 0.94 as expected
> ../../graphics/numericIndexPage.svg failed 0.94 as expected
> ../../../graphics/numericIndexPage.svg failed 0.94 as expected
>
> Marijan (Mario) Madunic
> Publishing Specialist
> New Flyer Industries
>
> -----Original Message-----
> From: Pascal Sancho [mailto:pascal.sancho@takoma.fr] 
>
> Hi Mario,
>
> This should work. I suspect that the relative URL is the cause of your
> trouble. Can you check it with an absolute path?
>
> Pascal
>
> Mario Madunic a écrit :
>   
>> I was doing the following with FOP 0.94 while testing
>>
>> <fo:region-body region-name="sectionBody_NI" background-image="bg.svg" background-repeat="no-repeat"
../>
>> And it would appear as a bg on the page.
>>
>> But in 0.95 that doesn't seem to work. How can I get an SVG as a background to work
in 0.95. One constraint is that the odd and even pages in this case each have a different
bg image.
>>
>> Marijan (Mario) Madunic
>>     


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message