xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chen Yang" <cy...@hrsg.ca>
Subject FW: Can't get RTF page break working
Date Wed, 20 Oct 2010 19:13:24 GMT
Hello list,

I have tried to get the rtf page break working with fop trunk, but seem
going nowhere so far.

 

I played around with Fop 0.95 and recently upgrade to Fop 1.0 for the
project I am working on. But soon I discovered RTF page break is only
available in fop trunk with RTFlib(jfor)

So I spend some time use ANT 1.8.1 to build fop trunk with CentOS 5.5

 

Here is my code 

 

<fo:table xsl:use-attribute-sets="table_p" break-after="page">

.

.

.

</fo:table>

 

Or

        

<fo:block xsl:use-attribute-sets="competency-group-name"
break-before="page">

    <xsl:apply-templates/>

</fo:block>

 

And here is the command I used 

 

"# Fop -xml scource.xml -xsl dic_new.xsl -rtf test_1.1.rtf"

 

Result was I can get the rtf file but all the tables are still stuck in
one page.

 

I tried to run Page_Break.fo (see attachment) which I found from the
mail-list, also can't get it work.

 

Since I am a newbie with FOP and Java, I have no idea what is wrong and
how I can get this working,

 

If anyone can give me some guide on this, I'll be much appreciated,

 

Thanks in advance 

 

Chen Yang


Programmer / Analyst

HRSG (Human Resource Systems Group)

Email:     cyang@hrsg.ca <mailto:cyang@hrsg.ca> 

Web:       www.hrsg.ca <http://www.hrsg.ca/> 

 


Mime
View raw message