xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mehdi houshmand <med1...@gmail.com>
Subject Fwd: RTF file
Date Mon, 25 Oct 2010 15:54:52 GMT
Hi Chen,

Just for future notice could you reply to the fop-users mailing list,
it means that the everyone sees your queries and can help accordingly.
Also, it means if other people run into these issues they can search
the mailing list.

Anyway, that aside, I took a look at the code and it seems the patch
referring to bug #42600 only fixed this issue for an <fo:block>, it
didn't implement any break-ing to any other object for which
"break-before" or "break-after" are valid attributes. This is clearly
a limitation but the bug fix is still valid, since it refers solely to
the <fo:block> object (see bug description). I think in this case it
would be valid to open a new bug concerning this issue and i have done
so (see URL) https://issues.apache.org/bugzilla/show_bug.cgi?id=50150.

Thanks

Mehdi


---------- Forwarded message ----------
From: Chen Yang <cyang@hrsg.ca>
Date: 25 October 2010 15:50
Subject: RTF file
To: mehdi houshmand <med1985@gmail.com>


Hey Mehdi,



I have tried your fo file,RTF Page break is working fine for me as
long as I put break-after or break-before on <fo:block>.

But if I put it on <fo:table> let’s say  <fo:table break-after=”page”>
and It won’t work anymore.



I've attached the FO file and result RTF files.



Have a good week,



Thanks



Chen Yang

Mime
View raw message