xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pascal Sancho <pascal.san...@takoma.fr>
Subject Re: Fop 1.0: resolving relative Font URLs
Date Thu, 14 Apr 2011 12:41:41 GMT
Hi,

Relative font path works for me on embed-url attribute (Windows + JDK
6.0.20), whatever FOP version (0.95, 1.0, or TRUNK):

Either on my dev machine (invoking FOP via CLI):
<snip>
<font-base>file:///D:/fonts</font-base>
<font kerning="yes" embed-url="dejavu/DejaVuSans.ttf">...</font>
</snip>

Or in production env (WinServer + JRE5 + Jboss):
 - same font element in fop.xconf,
 - but font-base set via
fopFactory.setFontBaseURL("file:///my/absolute/path")



no
Le 13/04/2011 18:26, Terence M. Bandoian a écrit :
>   On 4/13/2011 10:54 AM, Andreas L. Delmelle wrote:
>> On 13 Apr 2011, at 17:33, Ulrich Mayring wrote:
>>
>> Hi Ulrich
>>
>>> All I'm doing is replace fop-0.95.jar with fop-1.0.jar and our
>>> application ceases to work.
>> Just a thought: it might be that the font-cache has also changed slightly between
the two versions.
>>
>> Try adding a line to your code like
>>
>>    fopFactory.getFontManager().setUseCache(false);
>>
>> If that works, the more permanent solution would be to delete and regenerate the
font-cache to get everything to work as expected with 1.0.
>>
> 
> Hi, Ulrich-
> 
> That matches my experience with 1.0.  Setting font-base works with 
> metric-url but I've used absolute paths for embed-url.
> 
> -Terence Bandoian
-- 
Pascal

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message