xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Browder <tom.brow...@gmail.com>
Subject Missing Font for SVG to PDF Output
Date Wed, 13 Apr 2011 23:33:57 GMT
I have been happily using fop 1 (Linux, Ubuntu, x86_64) with my custom
fonts for some time and have had no problems using my Linux Libertine
and Biolinum fonts (ttf format).  Now I have started using svg for
equations and am having some problems.

First I started getting some mysterious font families mentioned in the
fop output while generating pdf, to wit:

Apr 13, 2011 4:09:16 PM org.apache.fop.events.LoggingEventListener processEvent
WARNING: Glyph "?" (0x2264, lessequal) not available in font "Helvetica".

I kept adding new substitutions to the <substtutions/> element in my
FOP configuration file until I eliminated all such warnings.

My remaining problem is the equation's italic text is still rendered
as sans-serif instead of serif as desired!

I understand there is some issue with fonts for Batik versus fop, but
I have ensured my Libertine font is in the system fontconfig so I
assume a disconnect between fop and batik is not the problem (but I
don't know that is true).

I can get the desired font on output if I simplify my equation some
but I can see no reason why that is so.

Does anyone have any suggestions?

Thanks so much.

-Tom

Thomas M. Browder, Jr.
Niceville, Florida
USA

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message