xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From MichaƂ Bartnicki <mbartni...@gmail.com>
Subject Embedding font on Solaris
Date Fri, 15 Apr 2011 15:39:53 GMT
Hi,

I'm trying to deploy my solution on Solaris server. It is a webservice
which uses FOP to generate pdf, pcl from xml and xsltfo.

The problem is that no matter what I do with config file FOP always
uses Helvetica instead of defined font (i've got my company font, and
tried calibri just for test).

What I've did:
- put fonts to /opt/szablony_wydrukow/fonts
- genereted metrics for all fonts
- tried smth like this in config:

<renderer mime="application/pdf">
      <filterList>
        <value>flate</value>
      </filterList>
<directory recursive="true">/opt/szablony_wydrukow/fonts</directory>
</renderer>

- then tried this:

<renderer mime="application/pdf">
      <filterList>
        <value>flate</value>
      </filterList>
	<fonts>
        <font metrics-url="Office.ttf.xml" kerning="yes" embed-url="Office.ttf">
          <font-triplet name="Office" style="normal" weight="normal"/>
        </font>
        <font metrics-url="Office_Bold.ttf.xml" kerning="yes"
embed-url="Office_Bold.ttf">
          <font-triplet name="Office" style="normal" weight="bold"/>
        </font>
      </fonts>
    </renderer>

I've tried this on local winxp and it did fine. The font was embedded
as it shoud. What I'm doing wrong?

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message