xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philippe Juhel" <philippe.ju...@icam.fr>
Subject Problem with arial font access
Date Mon, 05 Sep 2011 09:42:33 GMT
Hi, 

 

I run the 1.0 FOP version on a XP windows system.

If I don’t specify a configuration file (fop –fo test.xsl –pdf res.pdf), I
get the following warnings : 

 

5 sept. 2011 11:19:51 org.apache.fop.events.LoggingEventListener
processEvent

ATTENTION: Font "arial,normal,400" not found. Substituting with
"any,normal,400".

5 sept. 2011 11:19:51 org.apache.fop.events.LoggingEventListener
processEvent

ATTENTION: Font "arial,normal,700" not found. Substituting with
"any,normal,700".

 

Now, I use the template for the configuration file and I add the following
lines : 

 

<font kerning="yes"

      embed-url="file:///C:/windows/fonts/arial.ttf">

     <font-triplet name="arial" style="normal" weight="normal"/>

  </font>

  <font kerning="yes"

      embed-url="file:///C:/windows/fonts/arialbd.ttf">

     <font-triplet name="arial" style="normal" weight="bold"/>

  </font>

 

And with 

fop –c fop.xconf –fo test.xsl –pdf res.pdf

 

it works (no more warning about arial not found).

 

But it’s not really practical, easy to use a configuration file and add ALL
the fonts I want to use. Is it possible to just specify a folder with a lot
of fonts (like C:\windows\fonts) and have all the fonts automatically
available?

 

I try  :

<auto-detect/>

Or 

<directory>C:\windows\fonts</directory>

 

But it doesn’t work.

 

Any idea?

 

Regards,

 

Philippe Juhel

Assistant au pôle GEI (Génie Electronique et Informatique)

ICAM

75, av de Grande Bretagne

31300 Toulouse

Tél : 05-34-50-50-45

Mail : philippe.juhel@icam.fr

 


Mime
View raw message