xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mehdi houshmand <med1...@gmail.com>
Subject Re: Problem with arial font access
Date Mon, 05 Sep 2011 10:20:37 GMT
Hi Philippe,

You can try and get that working, but there are several considerations
you must take if you're wanting to use the  "<auto-detect.>" feature,
the most significant of which is that the name you set in
"font-family" must match the system font name. IMO configuring the
fonts explicitly minimizes problems in the long run, obviously there's
an initial overhead.

Hope that helps

Mehdi

On 5 September 2011 10:42, Philippe Juhel <philippe.juhel@icam.fr> wrote:
> Hi,
>
>
>
> I run the 1.0 FOP version on a XP windows system.
>
> If I don’t specify a configuration file (fop –fo test.xsl –pdf res.pdf), I
> get the following warnings :
>
>
>
> 5 sept. 2011 11:19:51 org.apache.fop.events.LoggingEventListener
> processEvent
>
> ATTENTION: Font "arial,normal,400" not found. Substituting with
> "any,normal,400".
>
> 5 sept. 2011 11:19:51 org.apache.fop.events.LoggingEventListener
> processEvent
>
> ATTENTION: Font "arial,normal,700" not found. Substituting with
> "any,normal,700".
>
>
>
> Now, I use the template for the configuration file and I add the following
> lines :
>
>
>
> <font kerning="yes"
>
>       embed-url="file:///C:/windows/fonts/arial.ttf">
>
>      <font-triplet name="arial" style="normal" weight="normal"/>
>
>   </font>
>
>   <font kerning="yes"
>
>       embed-url="file:///C:/windows/fonts/arialbd.ttf">
>
>      <font-triplet name="arial" style="normal" weight="bold"/>
>
>   </font>
>
>
>
> And with
>
> fop –c fop.xconf –fo test.xsl –pdf res.pdf
>
>
>
> it works (no more warning about arial not found).
>
>
>
> But it’s not really practical, easy to use a configuration file and add ALL
> the fonts I want to use. Is it possible to just specify a folder with a lot
> of fonts (like C:\windows\fonts) and have all the fonts automatically
> available?
>
>
>
> I try  :
>
> <auto-detect/>
>
> Or
>
> <directory>C:\windows\fonts</directory>
>
>
>
> But it doesn’t work.
>
>
>
> Any idea?
>
>
>
> Regards,
>
>
>
> Philippe Juhel
>
> Assistant au pôle GEI (Génie Electronique et Informatique)
>
> ICAM
>
> 75, av de Grande Bretagne
>
> 31300 Toulouse
>
> Tél : 05-34-50-50-45
>
> Mail : philippe.juhel@icam.fr
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message