xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Theresa Jayne Forster" <ther...@inbrand.co.uk>
Subject RE: Batik Problems
Date Thu, 02 Feb 2012 13:08:24 GMT
Ok, looking deeper I am seeing a problem loading any jpg images with fop,
any suggestions on this?

 

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - No
ImageLoaderFactory found that can load this format (image/jpeg;Raw)
directly. Trying ImageConverters instead...

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - No
ImageLoaderFactory found that can load this format (image/jpeg;Raw)
directly. Trying ImageConverters instead...

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - Lowest
penalty: 2147483647

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - Lowest
penalty: 2147483647

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - No route
found!

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - No route
found!

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - No
ImageLoaderFactory found that can load this format (RawCCITTFax) directly.
Trying ImageConverters instead...

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - No
ImageLoaderFactory found that can load this format (RawCCITTFax) directly.
Trying ImageConverters instead...

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - Lowest
penalty: 2147483647

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - Lowest
penalty: 2147483647

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - No route
found!

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - No route
found!

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - No
ImageLoaderFactory found that can load this format (Graphics2DImage)
directly. Trying ImageConverters instead...

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - No
ImageLoaderFactory found that can load this format (Graphics2DImage)
directly. Trying ImageConverters instead...

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - Lowest
penalty: 10

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - Lowest
penalty: 10

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - Pipeline:
Loader: org.apache.fop.image.loader.batik.ImageLoaderSVG@347cb44d
Converters:
[org.apache.fop.image.loader.batik.ImageConverterSVG2G2D@bf2428d] with
penalty 10

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - Pipeline:
Loader: org.apache.fop.image.loader.batik.ImageLoaderSVG@347cb44d
Converters:
[org.apache.fop.image.loader.batik.ImageConverterSVG2G2D@bf2428d] with
penalty 10

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - No
ImageLoaderFactory found that can load this format (BufferedImage) directly.
Trying ImageConverters instead...

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - No
ImageLoaderFactory found that can load this format (BufferedImage) directly.
Trying ImageConverters instead...

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - Lowest
penalty: 2147483647

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - Lowest
penalty: 2147483647

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - No route
found!

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - No route
found!

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - No
ImageLoaderFactory found that can load this format (RenderedImage) directly.
Trying ImageConverters instead...

2012-02-02 12:51:38,378 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - No
ImageLoaderFactory found that can load this format (RenderedImage) directly.
Trying ImageConverters instead...

2012-02-02 12:51:38,379 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - Lowest
penalty: 2147483647

2012-02-02 12:51:38,379 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - Lowest
penalty: 2147483647

2012-02-02 12:51:38,379 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - No route
found!

2012-02-02 12:51:38,379 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - No route
found!

2012-02-02 12:51:38,379 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - Pipeline:
Loader: org.apache.fop.image.loader.batik.ImageLoaderSVG@67214626 with
penalty 0

2012-02-02 12:51:38,379 [pool-1-thread-2] DEBUG
org.apache.xmlgraphics.image.loader.pipeline.PipelineFactory - Pipeline:
Loader: org.apache.fop.image.loader.batik.ImageLoaderSVG@67214626 with
penalty 0

 

Kindest regards

 


Theresa Forster

Senior Software Developer 

 

From: Theresa Jayne Forster [mailto:theresa@inbrand.co.uk] 
Sent: 02 February 2012 11:58
To: fop-users@xmlgraphics.apache.org
Subject: Batik Problems

 

Ok I have solved my batik issue, apparently you cannot use one-jar to create
a standalone jar as it cannot get the default CSS and XSD files from the
library batik jars. 

 

So changing to using maven assembly plugin it now puts the jars in unpacked,
so the classes and files are available.

Now the images are not working..

 

2012-02-02 11:43:22,638 [pool-1-thread-2] ERROR
org.apache.fop.apps.FOUserAgent - Image not found. URI:
\InBrand\preprocessor\filestore\img3980813249191582957.jpg. (No context info
available)

2012-02-02 11:43:22,638 [pool-1-thread-2] ERROR
org.apache.fop.apps.FOUserAgent - Image not found. URI:
\InBrand\preprocessor\filestore\img3980813249191582957.jpg. (No context info
available)

 

I have the BASEURL set in the fopconfig.xml file as "/"

I also tried accessing them as explicit paths

 

2012-02-02 11:56:54,428 [pool-1-thread-4] ERROR
org.apache.fop.apps.FOUserAgent - Image not found. URI:
C:\InBrand\preprocessor\filestore\img4930914128352311319.jpg. (No context
info available)

2012-02-02 11:56:54,428 [pool-1-thread-4] ERROR
org.apache.fop.apps.FOUserAgent - Image not found. URI:
C:\InBrand\preprocessor\filestore\img4930914128352311319.jpg. (No context
info available)

 

I just saw the following in the logs. Why is it trying to load a jpg as an
SVG?

 

2012-02-02 11:48:19,973 [pool-1-thread-2] DEBUG
org.apache.fop.image.loader.batik.PreloaderSVG - Error while trying to load
stream as an SVG file: Invalid byte 1 of 1-byte UTF-8 sequence.

2012-02-02 11:48:19,973 [pool-1-thread-2] DEBUG
org.apache.fop.image.loader.batik.PreloaderSVG - Error while trying to load
stream as an SVG file: Invalid byte 1 of 1-byte UTF-8 sequence.

2012-02-02 11:48:19,974 [pool-1-thread-2] ERROR
org.apache.fop.apps.FOUserAgent - Image not available. URI:
\InBrand\preprocessor\filestore\img3970845222913192771.jpg. Reason:
org.apache.xmlgraphics.image.loader.ImageException: The file format is not
supported. No ImagePreloader found for
\InBrand\preprocessor\filestore\img3970845222913192771.jpg (See position
1296:195)

2012-02-02 11:48:19,974 [pool-1-thread-2] ERROR
org.apache.fop.apps.FOUserAgent - Image not available. URI:
\InBrand\preprocessor\filestore\img3970845222913192771.jpg. Reason:
org.apache.xmlgraphics.image.loader.ImageException: The file format is not
supported. No ImagePreloader found for
\InBrand\preprocessor\filestore\img3970845222913192771.jpg (See position
1296:195)

 

 

Can anyone suggest why this was working and now is not?

 

Kindest regards

 


Theresa Forster

Senior Software Developer



 


Mime
View raw message