xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Bowditch <bowditch_ch...@hotmail.com>
Subject Re: Fonts in config file
Date Thu, 12 Apr 2012 15:29:35 GMT
On 12/04/2012 14:00, froglander wrote:
> If I have<auto-detect />  in the userconfig.xml file this line
>
> <fo:inline font-size="8pt" font-family="Symbol">•</fo:inline>
>
> Ends up displaying as a # symbol in the resulting pdf file print.
>
> If I take<auto-detect />  out of the userconfig.xml file, then the above
> line works but the following line does not.

That's because there are 2 version of the font named Symbol; The Base 14 
font Symbol that is included with FOP by default. That is the version 
used when <auto-detect/> is absent from the fop.xconf file and the 
symbol.ttf file installed in the operating system. The bullet character 
is not present in the Operating System version of Symbol or at least its 
accessed via a different Unicode reference.

>
> <fo:inline font-size="11pt" font-family="Arial, sans-serif">Ω</fo:inline>

Arial is not available as part of the Base 14 fonts, so you must 
register it in the fop.xconf. Since <auto-detect/> adds every font 
installed in the Operating System I suggest you manually add individual 
fonts that you wish to use (such as Arial) using the <font> element as 
described in [1]

Thanks,

Chris

[1] http://xmlgraphics.apache.org/fop/1.0/fonts.html#register

>
> Is any more information needed?  I need this to be able to show bulleted
> lists as well as possible 'special' characters.
>
> Thanks!
>
>
>
> froglander wrote:
>> In this case it is using te symbol font for the bullets.
>>
>> Rob Sargent-4 wrote:
>>> Not all fonts have bullets.  Which are you using?
>>>
>>> rjs
>>>
>>> On 04/11/2012 02:34 PM, froglander wrote:
>>>> I am using FOP 1.0 and am having difficulty getting bullets and symbols
>>>> to
>>>> display correctly.
>>>>
>>>> I have found that if I take the<auto-detect />   the bullets for the
>>>> bulleted
>>>> list (rich text format) will show, but them some other symbols (like the
>>>> Ohm
>>>> symbol, etc) show as #.  If I keep the<auto-detect />   in, the bulleted
>>>> list
>>>> shows as # symbols, but the Ohm symbol, etc display correctly.
>>>>
>>>> Is something missing for the fonts?
>>>>
>>>> Thanks!
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
>>> For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org
>>>
>>>
>>>
>>


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message