xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Craig <mark.cr...@gmail.com>
Subject Re: Eliminating soft hyphens shown in mid line?
Date Fri, 19 Apr 2013 15:52:40 GMT
Thanks,

I have filed https://issues.apache.org/jira/browse/FOP-2239.

Mark

On Apr 19, 2013, at 5:32 PM, Glenn Adams wrote:

> You can start by filing a bug in JIRA, and supplying the following:
> 
> (1) input XSL-FO test file, in a maximally minimal form to show the problem
> (2) sample output PDF from that input, showing the problem
> (3) information about version and configuration
> (4) any console output produced
> 
> See [1] for creating a bug in JIRA.
> 
> [1] https://issues.apache.org/jira/browse/FOP
> 
> 
> On Fri, Apr 19, 2013 at 2:58 AM, Mark Craig <mark.craig@gmail.com> wrote:
> Hello,
> 
> Recently I started using soft hyphens with FOP to split some painfully long Java properties
at . In most cases, this has worked very well and been a significant improvement.
> 
> There seems to be some cases, however, where soft hyphens show up in mid line when followed
by punctuation characters like ., ], and ".
> 
> I find the excerpt of the attached .fo:
> 
>         <fo:block><fo:inline font-size="0.9em">.&#xAD;.&#xAD;</fo:inline></fo:block>
>         <fo:block><fo:inline font-size="0.9em">.&#xAD; .&#xAD;</fo:inline></fo:block>
>         <fo:block><fo:inline font-size="0.9em">.&#xAD;</fo:inline></fo:block>
>         <fo:block><fo:inline font-size="0.9em">.&#xAD;]</fo:inline></fo:block>
>         <fo:block><fo:inline font-size="0.9em">.&#xAD;\</fo:inline></fo:block>
>         <fo:block><fo:inline font-size="0.9em">.&#xAD;"</fo:inline></fo:block>
>         <fo:block><fo:inline font-size="0.9em">.&#xAD;a</fo:inline></fo:block>
>         <fo:block><fo:inline font-size="0.9em">.&#xAD;Z</fo:inline></fo:block>
> 
> Looks like this in PDF output:
> 
> .-.
> . .
> .
> .-]
> .\
> .-"
> .a
> .Z
> 
> I am seeing this behavior with FOP 1.0, FOP 1.1, and FOP 20130418 nightly build.
> 
> What should I do to eliminate the soft hyphens showing up in mid line (not before a line
break)?
> 
> Thank you for your help.
> Regards,
> Mark
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
> For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org
> 


Mime
View raw message