xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luis Bernardo <lmpmberna...@gmail.com>
Subject Re: Cyrrilic font in Apache FOP 1.1
Date Sat, 16 Nov 2013 20:50:43 GMT
On 11/16/13, 8:41 PM, Luis Bernardo wrote:
>
> With trunk use:
>         FopFactoryBuilder builder = new FopConfParser(new 
> File(confFile)).getFopFactoryBuilder();
>         FopFactory fopFactory = builder.build();
>
> On 11/15/13, 6:23 PM, Gonzalo Vasquez wrote:
>> Hmmmm..I'm using the trunk version for FOP, and methods seems to have 
>> changed their signature :(
>>
>> El 15-11-2013, a las 15:21, Amigo <et_soft@mail.ru 
>> <mailto:et_soft@mail.ru>> escribió:
>>
>>>
>>> Configuration cfg = cfgBuilder.buildFromFile(new 
>>> File("/home/name/temp/fonts/userconfig.xml"));
>>> Fop fop = fopFactory.newFop(MimeConstants.MIME_PDF, out);
>>> fopFactory.setUserConfig(cfg);
>>>
>>>
>>> 2013/11/15 Gonzalo Vasquez [via Apache FOP] <[hidden email] 
>>> <x-msg://22/user/SendEmail.jtp?type=node&node=39597&i=0>>
>>>
>>>     Same problem here!
>>>
>>>     How are you telling your code to use such config file?
>>>
>>>
>>>     El 15-11-2013, a las 14:47, Amigo <[hidden email]
>>>     <http://user/SendEmail.jtp?type=node&node=39596&i=1>> escribió:
>>>
>>>     > I have trouble on using Apache FOP 1.1 with arial font on ubuntu.
>>>     >
>>>     > Configuration file fonts.xml:
>>>     >
>>>     >   / <fop version="1.0">
>>>     >  <base>/home/user/temp/fonts/</base>
>>>     >  <font-base>/home/user/temp/fonts/</font-base>
>>>     >     <renderers>
>>>     >    <renderer mime="application/pdf">
>>>     >    <fonts>
>>>     >
>>>     >       <font-triplet name="Arial" style="normal"
>>>     weight="normal" />
>>>     >       <font-triplet name="ArialMT" style="normal"
>>>     weight="normal" />
>>>     >
>>>     >   </fonts>
>>>     >    </renderer>
>>>     >  </renderers>
>>>     >    </fop>/
>>>     > Also tried using this:
>>>     >
>>>     > /<auto-detect/> /
>>>     > and
>>>     >
>>>     > /<directory>/home/user/temp/fonts/</directory>/
>>>     > I am always getting:
>>>     >
>>>     > Font "Arial,normal,700" not found. Substituting with
>>>     "any,normal,700".
>>>     >
>>>     > What should I fix in order to use Arial font?
>>>     >
>>>     >
>>>     >
>>>     > --
>>>
>


Mime
View raw message