xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luis Bernardo <lmpmberna...@gmail.com>
Subject Re: Problem with TIFF in fop trunk
Date Wed, 20 Nov 2013 23:34:41 GMT

I am unable to reproduce the problem. I am also using Mac OS X 10.9, and 
same trunk revision.

Can you try to place the image on the local disk (instead of retrieving 
it from a web server) to check whether that is causing the problem?

On 11/20/13, 8:55 PM, Joe Wicentowski wrote:
> Hi all,
>
> I recently built FOP for the first time to see if a problem I was
> experiencing under 1.1 (it would consistently hang when rendering a
> certain page) would go away if I tried trunk.  While trunk does now
> overcome the problem I was having under 1.1, I am experiencing a new
> problem: a TIFF that I embed on the cover page of my output was
> displaying correctly under 1.1 but is now appearing as a squat, opaque
> black box in the PDF generated under trunk.
>
> I'm running fop trunk rev. 1543560 on Mac OS X 10.9, and ran fop on
> the command line:
>
>    $ ~/workspace/fop/fop -d -c fop-config.xml -fo frus1969-76v03.fo
> -pdf frus1969-76v03.pdf
>
> I don't get any errors in the output about the image (which is stored
> on a local server at being inaccessible.
>
> I've uploaded sample fo, the image, and the resulting PDF at the following URLs:
>
>    http://static.history.state.gov/temp/fop/frus1969-76v03-cover.fo
>    http://static.history.state.gov/temp/fop/frus1969-76v03-cover.pdf
>    http://static.history.state.gov/temp/fop/Image_0001.tiff
>    http://static.history.state.gov/temp/fop/fop-config.xml
>
> The problem is apparent on the PDF, where I would expect to see
> Image_0001.tiff embedded but instead see an opaque black box.
> According to the docs
> (http://xmlgraphics.apache.org/fop/trunk/graphics.html#tiff), this
> CCITT Group IV-encoded TIFF image should be compatible with FOP.  And
> it rendered fine under 1.1.
>
> I'd appreciate any suggestions you might have.  I'm not quite sure
> what to try next.
>
> Thank you,
> Joe
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
> For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message