xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amigo <et_s...@mail.ru>
Subject Re: Cyrrilic font in Apache FOP 1.1
Date Sat, 16 Nov 2013 15:19:29 GMT
Any other ideas?
Nobody uses FOP 1.1?




2013/11/16 Et_soft <et_soft@mail.ru>

>
> Dit not help. Same problem. :(
>
> Interesting, if i change font name, FOP dot't write any error, like 'file
> not found'. Is it normal?
>
> <font kerning="yes" embed-url="/home/name/temp/fonts/arial121334.ttf"
> embedding-mode="subset">
>     <font-triplet name="Arial" style="normal" weight="normal"/>
>
>
> 2013/11/16 Simon Steiner [via Apache FOP] <
> ml-node+s1065347n39599h75@n5.nabble.com>
>
>  Hi,
>>
>> What about using
>>
>> <renderers>
>>    <renderer mime="application/pdf">
>>        <fonts>
>>            <font kerning="yes"
>> embed-url="/System/Library/Fonts/Arial.ttf"
>> embedding-mode="subset">
>>                <font-triplet name="Arial" style="normal"
>> weight="normal"/>
>>            </font>
>>        </fonts>
>>    </renderer>
>> </renderers>
>>
>> http://xmlgraphics.apache.org/fop/trunk/fonts.html
>>
>> Thanks
>>
>> -----Original Message-----
>> From: Amigo [mailto:[hidden email]<http://user/SendEmail.jtp?type=node&node=39599&i=0>]
>>
>> Sent: 15 November 2013 17:47
>> To: [hidden email] <http://user/SendEmail.jtp?type=node&node=39599&i=1>
>> Subject: Cyrrilic font in Apache FOP 1.1
>>
>> I have trouble on using Apache FOP 1.1 with arial font on ubuntu.
>>
>> Configuration file fonts.xml:
>>
>>    / <fop version="1.0">
>>     <base>/home/user/temp/fonts/</base>
>>     <font-base>/home/user/temp/fonts/</font-base>
>>      <renderers>
>>     <renderer mime="application/pdf">
>>     <fonts>
>>
>>        <font-triplet name="Arial" style="normal" weight="normal" />
>>        <font-triplet name="ArialMT" style="normal" weight="normal" />
>>
>>    </fonts>
>>     </renderer>
>>   </renderers>
>>     </fop>/
>> Also tried using this:
>>
>> /<auto-detect/> /
>> and
>>
>> /<directory>/home/user/temp/fonts/</directory>/
>> I am always getting:
>>
>> Font "Arial,normal,700" not found. Substituting with "any,normal,700".
>>
>> What should I fix in order to use Arial font?
>>
>>
>>
>> --
>> View this message in context:
>>
>> http://apache-fop.1065347.n5.nabble.com/Cyrrilic-font-in-Apache-FOP-1-1-tp39
>> 595.html
>> Sent from the FOP - Users mailing list archive at Nabble.com.
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]<http://user/SendEmail.jtp?type=node&node=39599&i=2>
>> For additional commands, e-mail: [hidden email]<http://user/SendEmail.jtp?type=node&node=39599&i=3>
>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]<http://user/SendEmail.jtp?type=node&node=39599&i=4>
>> For additional commands, e-mail: [hidden email]<http://user/SendEmail.jtp?type=node&node=39599&i=5>
>>
>>
>>
>> ------------------------------
>>  If you reply to this email, your message will be added to the
>> discussion below:
>>
>> http://apache-fop.1065347.n5.nabble.com/Cyrrilic-font-in-Apache-FOP-1-1-tp39595p39599.html
>>  To unsubscribe from Cyrrilic font in Apache FOP 1.1, click here<http://apache-fop.1065347.n5.nabble.com/template/NamlServlet.jtp?macro=unsubscribe_by_code&node=39595&code=ZXRfc29mdEBtYWlsLnJ1fDM5NTk1fC04MTg5MDU3NTI=>
>> .
>> NAML<http://apache-fop.1065347.n5.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>
>>
>
>




--
View this message in context: http://apache-fop.1065347.n5.nabble.com/Cyrrilic-font-in-Apache-FOP-1-1-tp39595p39604.html
Sent from the FOP - Users mailing list archive at Nabble.com.
Mime
View raw message