xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Wicentowski <joe...@gmail.com>
Subject Re: Problem with TIFF in fop trunk
Date Thu, 21 Nov 2013 03:15:52 GMT
And just to add one more point:

I downloaded the 1.1 binary to this same Mac and ran:

$ ~/Downloads/fop-1.1/fop -d -c fop-config.xml -fo
frus1969-76v03-cover.fo -pdf frus1969-76v03-cover2.pdf

(Using the same fop-config.xml as described in my original email.)
The resulting PDF has the TIFF image intact, as expected - no black
box as I got with my locally build and configured trunk.

I guess this points not to a system level issue but rather my method
of building or configuring fop trunk, right?

Joe

On Wed, Nov 20, 2013 at 10:03 PM, Joe Wicentowski <joewiz@gmail.com> wrote:
> Hi Luis,
>
> Thank you for your reply!  I just tried rebuilding on my other Mac and
> reproduced my earlier black box problem.  I also tried your suggestion
> to change the image reference to point to the local file system, with
> the same results:
>
> Original form of the image reference on line 27:
>   <fo:external-graphic
> src="url('http://localhost:8080/cms/apps/tei-content/images/Image_0001.tiff')"/>
>
> Form 2:
>   <fo:external-graphic src="url('Image_0001.tiff')"/>
>
> Form 3:
>   <fo:external-graphic
> src="url('http://localhost:8080/cms/apps/tei-content/images/Image_0001.tiff')"/>
>
> Given that you weren't able to reproduce the problem, I wonder if
> there could be a configuration problem on my side.  Here was my
> procedure after checking out trunk:
>
> First, I built fop using "ant package", based on the recommendation at
> http://xmlgraphics.apache.org/fop/trunk/compiling.html.
>
> Second, I set up this ~/.foprc file:
>
> FOP_OPTS="-Xmx2000m -Djava.awt.headless=true"
> FOP_HOME="~/workspace/fop/"
>
> Let me explain the values I chose: I set the Xmx because at first my
> transformations were stalling at around page 500 of a 1000-plus page
> publication, and raising the memory here allowed the transformation to
> complete.  I set headless=true because I was using a bash for loop on
> a directory of nearly 200 .fo files and the FOP icon kept stealing
> focus.  And this FOP_HOME "~/workspace/fop/" directory is where I
> checked out fop trunk, i.e., I ran chmod +x on ~/workspace/fop/fop to
> be able to call the command I listed before:
>
> $ ~/workspace/fop/fop {and so on...}
>
> Could something in my .foprc be messed up?
>
> Going further afield, I have this Oracle Java JDK:
>
> $ java -version
> java version "1.7.0_11"
> Java(TM) SE Runtime Environment (build 1.7.0_11-b21)
> Java HotSpot(TM) 64-Bit Server VM (build 23.6-b04, mixed mode)
>
> I also have the XCode Command Line Tools and homebrew installed with
> these packages:
>
> $ brew list
> ant automake graphviz libksba libtool openssl python sqlite
> autoconf gdbm libgpg-error libpng libyaml pkg-config readline
>
> If there's any other information I can provide, I'd be happy to.
>
> Thanks again,
> Joe
>
>
>> On Nov 20, 2013, at 6:34 PM, Luis Bernardo <lmpmbernardo@gmail.com> wrote:
>>
>> I am unable to reproduce the problem. I am also using Mac OS X 10.9, and same trunk
revision.
>>
>> Can you try to place the image on the local disk (instead of retrieving it from a
web server) to check whether that is causing the problem?
>>
>>> On 11/20/13, 8:55 PM, Joe Wicentowski wrote:
>>> Hi all,
>>>
>>> I recently built FOP for the first time to see if a problem I was
>>> experiencing under 1.1 (it would consistently hang when rendering a
>>> certain page) would go away if I tried trunk.  While trunk does now
>>> overcome the problem I was having under 1.1, I am experiencing a new
>>> problem: a TIFF that I embed on the cover page of my output was
>>> displaying correctly under 1.1 but is now appearing as a squat, opaque
>>> black box in the PDF generated under trunk.
>>>
>>> I'm running fop trunk rev. 1543560 on Mac OS X 10.9, and ran fop on
>>> the command line:
>>>
>>>   $ ~/workspace/fop/fop -d -c fop-config.xml -fo frus1969-76v03.fo
>>> -pdf frus1969-76v03.pdf
>>>
>>> I don't get any errors in the output about the image (which is stored
>>> on a local server at being inaccessible.
>>>
>>> I've uploaded sample fo, the image, and the resulting PDF at the following URLs:
>>>
>>>   http://static.history.state.gov/temp/fop/frus1969-76v03-cover.fo
>>>   http://static.history.state.gov/temp/fop/frus1969-76v03-cover.pdf
>>>   http://static.history.state.gov/temp/fop/Image_0001.tiff
>>>   http://static.history.state.gov/temp/fop/fop-config.xml
>>>
>>> The problem is apparent on the PDF, where I would expect to see
>>> Image_0001.tiff embedded but instead see an opaque black box.
>>> According to the docs
>>> (http://xmlgraphics.apache.org/fop/trunk/graphics.html#tiff), this
>>> CCITT Group IV-encoded TIFF image should be compatible with FOP.  And
>>> it rendered fine under 1.1.
>>>
>>> I'd appreciate any suggestions you might have.  I'm not quite sure
>>> what to try next.
>>>
>>> Thank you,
>>> Joe
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
>>> For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
>> For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org
>>

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message