xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Lehmann <e.lehman...@gmail.com>
Subject Fwd: FOP 1.0 Linux Arial not working
Date Wed, 26 Feb 2014 16:04:18 GMT
<renderers>
   <renderer mime="application/pdf">
  <fonts>
    <!-- arial -->
    <font metrics-url="/opt/fop/fonts/arial.xml" kerning="yes"
embed-url="/opt/fop/fonts/arial.ttf">
      <font-triplet name="Arial" style="normal" weight="normal"/>
    </font>
  </fonts>
 </renderer>
</renderers>


---------- Forwarded message ----------
From: Luis Bernardo <lmpmbernardo@gmail.com>
Date: 2014-02-26 16:48 GMT+01:00
Subject: Re: FOP 1.0 Linux Arial not working
To: "fop-users@xmlgraphics.apache.org" <fop-users@xmlgraphics.apache.org>


Is the font configured under the renderer element of the format you want to
produce?


On Wed, Feb 26, 2014 at 3:32 PM, Eric Lehmann <e.lehmann88@gmail.com> wrote:

> Hi
>
> I want to use Arial in my xsl stylesheet but there are several problems.
>
> FOP Version: Fop 1.0
> OS : SLES 11 SP2
>
> First I get the arial.ttf from a windows client.
> Generate the metrics file with:
>  java -cp
> "build/fop.jar:lib/avalon-framework-4.2.0.jar:lib/commons-logging-1.0.4.jar:lib/commons-io-1.3.1.jar:lib/xmlgraphics-commons-1.5.jar"
> org.apache.fop.fonts.apps.TTFReader /opt/fop/fonts/arial.ttf arial.xml
>
> To there everythings is ok....
>
> Then I add to config.xml:
>  <fonts>
>     <!-- arial -->
>     <font metrics-url="/opt/fop/fonts/arial.xml" kerning="yes"
> embed-url="/opt/fop/fonts/arial.ttf">
>       <font-triplet name="Arial" style="normal" weight="normal"/>
>     </font>
>   </fonts>
>
> And run fop with:
> /opt/fop/fop.sh -c /opt/fop/conf/config.xml -d  -fo /tmp/test.fo -pdf
> /tmp/test.pdf
>
> Which gives me such output:
> WARNING: Font "Arial,normal,400" not found. Substituting with
> "any,normal,400".
>
> Where is my fautl??
>
> THX a lot and regards from Germany.
>
>
>

Mime
View raw message