xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Wicentowski <joe...@gmail.com>
Subject Re: Problem spanning across columns
Date Wed, 09 Jul 2014 18:49:20 GMT
Hi all,

I just found a helpful post from the list archives:

  http://markmail.org/message/aexsnpg45wvqirby

... which cites section 7.21.4 of the spec about @span,
http://www.w3.org/TR/xsl/#span:

  "This only has effect on areas returned by a flow; e.g. block-areas
generated by fo:block children of an fo:flow. Children and further
descendants of these areas take on the spanning characteristic of
their parent."

Moving my two fo:blocks so they're direct children of the fo:flow did
the trick.  Which is great - though it feels a bit kludgy.

Thanks,
Joe

On Wed, Jul 9, 2014 at 2:26 PM, Joe Wicentowski <joewiz@gmail.com> wrote:
> Hello all,
>
> I've been working on a two-column back-of-book index, but I would like
> two fo:blocks that precede the index's fo:list-block to span the
> columns.  I've added @span="all" to the two fo:blocks, but the blocks
> are being rendered into the first column.  I've attached a sample FO
> file and the resulting PDF that I'm seeing.  Could someone please
> guide me in forcing the two fo:blocks (lines 103-107) to span across
> both columns?
>
> Thanks in advance,
> Joe

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message