xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Retter <adam.ret...@googlemail.com>
Subject Invalid Avalon Maven dependenices
Date Thu, 16 Jul 2015 15:45:16 GMT
In your POM file for fop 1.1 and fop 2.0 published to Maven Central,
e.g. https://repo1.maven.org/maven2/org/apache/xmlgraphics/fop/1.1/fop-1.1.pom

You have the two dependencies:

<dependency>
  <groupId>org.apache.avalon.framework</groupId>
  <artifactId>avalon-framework-api</artifactId>
  <version>4.2.0</version>
</dependency>
<dependency>
  <groupId>org.apache.avalon.framework</groupId>
  <artifactId>avalon-framework-impl</artifactId>
  <version>4.2.0</version>
</dependency>

Unfortunately those artifacts do not seem to be present in Maven
Central or any other public repo that I can find. I can however find
in Maven Central the same artifacts but under a different group id,
i.e.:

<dependency>
  <groupId>avalon-framework</groupId>
  <artifactId>avalon-framework-api</artifactId>
  <version>4.2.0</version>
</dependency>
<dependency>
  <groupId>avalon-framework</groupId>
  <artifactId>avalon-framework-impl</artifactId>
  <version>4.2.0</version>
</dependency>

So what I am wondering is which of these is the case:
1) are your POM files in Maven Central wrong?
2) Have you or someone else failed to upload the necessary avalon
artifacts to Maven Central?
3) Is there some other public repo just for these avalon dependencies
that I should have used?

Trying to use FOP in a Maven project at the moment seems to be
impossible without manually installing the avalon dependencies
locally.

Thanks Adam.

-- 
Adam Retter

skype: adam.retter
tweet: adamretter
http://www.adamretter.org.uk

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message