xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tobias Fischer | pagina GmbH <tobias.fisc...@pagina.gmbh>
Subject Missing text when printing FOP 2.1 PDF documents in Mac OSX's Preview App
Date Thu, 18 Aug 2016 13:38:14 GMT
hi all,

we're using latest FOP version 2.1 to generate book PDFs.
While testing, we noticed that printing the generated PDF's in Mac OS 
X's "Preview" app (their default pdf viewer) will result in missing 
texts on the printed page.
This does not happen with Acrobat Reader on Windows nor in Acrobat on 
Mac OS X – only the Preview App seems to get it wrong.

Fonts:
- "Minion Pro" OTF fonts (loaded from local folder via fop.xconf -> 
font-triplets)

Printer:
- Lexmark M5155
- Konica Minolta Bizhub C452

fop.xconf:
> <?xml version="1.0" encoding="UTF-8"?>
> <fop version="1.0">
>   <renderers>
>     <renderer mime="application/pdf">
>       <filterList>
>         <!-- Compression using zlib flate (default is on). -->
>         <value>flate</value>
>       </filterList>
>
>       <fonts>
>         <auto-detect/>
>
>         <font embed-url="fonts/MinionPro-Regular.otf">
>           <font-triplet name="Minion Pro" style="normal" weight="normal"/>
>         </font>
>         <font embed-url="fonts/MinionPro-It.otf">
>           <font-triplet name="Minion Pro" style="italic" weight="normal"/>
>         </font>
>         <font embed-url="fonts/MinionPro-Bold.otf">
>           <font-triplet name="Minion Pro" style="normal" weight="bold"/>
>         </font>
>         <font embed-url="fonts/MinionPro-BoldIt.otf">
>           <font-triplet name="Minion Pro" style="italic" weight="bold"/>
>         </font>
>         <!-- ... and some others ... -->
>       </fonts>
>     </renderer>
>   </renderers>
> </fop>

Attached you will find the first two pages from an example PDF as well 
as a photography of 2 printed pages (left: printed from windows, ignore 
the scale factor; right: printed from Preview on Mac OS X).
The cover image get's printed, the other text isn't printed. The link 
underline gets printed as well.

Does anyone have an idea what we did wrong? Or what FOP is doing wrong?

Thanks!

Best regards,
Tobias

-- 
Tobias Fischer
Senior Software Engineer
(XML/EPUB/PrintCSS)

Telefon: +49 (0)7071 9876-44 · Fax: -22
Mail: tobias.fischer@pagina.gmbh

pagina GmbH - Publikationstechnologien
Herrenberger Straße 51 | D-72070 Tübingen
www.pagina.gmbh | www.parsx.de

Handelsregister Stuttgart - HRB 380249
Geschäftsführer: Tobias Ott


Mime
View raw message