xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "arin.kundu" <arin.ku...@gmail.com>
Subject FOP 2.1 Transforming Western Non Latin Character as ?
Date Mon, 30 Oct 2017 15:56:39 GMT
Hello Experts,

FOP version: 2.1
Java version : 1.7.0_101
OS/Platform version : 
LSB_VERSION=base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
Red Hat Enterprise Linux Server release 6.6 (Santiago)

I don't observe any error messages at log and the xml to PDF transformation
happens correctly with '?' for the character “Å” 

>From forum and discussions I understood  - if the characters are being
replaced with ?s then there is a character mapping issue on the server,
could you please help me understand what are the details I need to check to
ensure the character mapping on the server is correct.

FOP config( Config.xml
<http://apache-fop.1065347.n5.nabble.com/file/t2923/Config.xml>  ) and the
XSL  Header.xsl
<http://apache-fop.1065347.n5.nabble.com/file/t2923/Header.xsl>  (used for
transformation) are included. I have verified all the fonts mentioned at
config.xml are located at the right place.



One more question -  output PDF has the font encoding as ansi, could this be
an issue? if "yes" how could we enforce the output pdf's font encoding to be
something else, may be 'UTF-8', screenshot included.

<http://apache-fop.1065347.n5.nabble.com/file/t2923/FO-PDF-Transformation-Issue.jpg>






--
Sent from: http://apache-fop.1065347.n5.nabble.com/FOP-Users-f3.html

---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message