xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthias Reischenbacher <matthias8...@gmx.at>
Subject Re: White space in FO causes PDF TOC problem
Date Mon, 26 Nov 2018 11:17:28 GMT
Hi,

yes, this is an unresolved FOP bug, see also:

https://issues.apache.org/jira/browse/FOP-1952

https://issues.apache.org/jira/browse/FOP-1839

Best regards,

Matthias


On 26.11.2018 01:21, Mark Giffin wrote:
> I'm using FOP 2.3 with the DITA Open Toolkit. The <title> tags in DITA
> topics are used in the table of contents in a PDF. Each table of
> contents line is justified like this in the PDF:
>
> (left margin)Intro to
> XYZ........................................................14(right
> margin)
> (left margin)Setting Up
> XYZ...................................................18(right margin)
>
> Most lines line up neatly on the right margin, but a few do not go to
> the margin. The cause of a line that does not go all the way to the
> right margin is a <title> tag with white space in it like this:
>
> <title>
>   Do This First
> </title>
>
> This white space gets copied over to the XSL-FO produced by the DITA OT:
>
> height="150%"><fo:inline end-indent="14pt">
>         Do This First
>     </fo:inline><fo:inline color="black"
> keep-together.within-line="always" start-indent="-14pt"><fo:leader
> color="black" leader-pattern="dots"/><fo:page-number-citation...
>
> And FOP renders this in the PDF like this, where the line does not go
> all the way to the right margin:
>
> (left margin)Do This
> First....................................................10 (right
> margin)
> (left margin)Intro to
> XYZ........................................................14(right
> margin)
> (left margin)Setting Up
> XYZ...................................................18(right margin)
>
> When I remove the whitespace in the XSL-FO, the line renders
> correctly, all the way to the right margin. Both Antenna House and XEP
> render the line correctly, ignoring the extraneous whitespace. This
> seems like a FOP bug, is there a fix for this? Other than removing the
> whitespace?
>
> Thanks,
> Mark
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
> For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: fop-users-help@xmlgraphics.apache.org


Mime
View raw message