xmlgraphics-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremias Maerki <...@jeremias-maerki.ch>
Subject Re: JAXP missing on JDK1.3 ant build
Date Tue, 29 May 2007 20:24:29 GMT
If I could place my preference, I'd still have a user-poll on both Batik
and FOP communities before going to a vote to change the minimum J2SE
level. From the two, the vote is the more important aspect. It's quite
an important move.

I was thinking about using one of those free online survey tools to get
qualified feedback on the J2SE levels in use and to get an idea how many
people are still on 1.3 and how they would be affected by the change.
Also questions like: If you'd want to upgrade FOP or Batik while on J2SE
1.3, why can't you upgrade J2SE, too (i.e. what platform are you on)?
But since I don't really have time to organize anything like that ATM,
I'm happy with a simple poll on the mailing list.

I think it would be great if we could do a concerted move inside the XML
Graphics project (all three products together).

On 29.05.2007 09:56:35 Chris Bowditch wrote:
> Vincent Hennebert wrote:
> 
> > Jeremias Maerki a écrit :
> > 
> >>I guess I never noticed that because I just install JAXP in Ant's lib
> >>folder. The dependency is documented in lib/README.txt so those very few
> >>who are going to compile Commons themselves on 1.3 will really not mind
> >>so much, I think. But bundling JAXP would mean increasing the
> >>distribution size a lot. And since we're likely moving away from 1.3 in
> >>the near future, I don't think it's worth the trouble. But that's just
> >>my opinion.
> > 
> > 
> > Speaking of that, BTW, why couldn't the "near future" actually be just
> > now? I remember we spoke of that on fop-dev a few months ago, and
> > basically agreed upon dropping 1.3 support after the 0.93 release, and
> > after having made a poll on fop-user. I think it's time to do it. Any
> > negative opinion?
> 
> Yes I remember the same discussion and thought we had finally decided to 
> drop support for 1.3 too. I think its about time we did, so +1 from me.
> 
> <snip/>
> 
> Chris



Jeremias Maerki


---------------------------------------------------------------------
Apache XML Graphics Project URL: http://xmlgraphics.apache.org/
To unsubscribe, e-mail: general-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: general-help@xmlgraphics.apache.org


Mime
View raw message