yetus-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sek...@apache.org
Subject [14/20] yetus git commit: YETUS-387. fix some dockerfile issues
Date Wed, 11 May 2016 21:41:36 GMT
YETUS-387. fix some dockerfile issues

Signed-off-by: Kengo Seki <sekikn@apache.org>


Project: http://git-wip-us.apache.org/repos/asf/yetus/repo
Commit: http://git-wip-us.apache.org/repos/asf/yetus/commit/6c003865
Tree: http://git-wip-us.apache.org/repos/asf/yetus/tree/6c003865
Diff: http://git-wip-us.apache.org/repos/asf/yetus/diff/6c003865

Branch: refs/heads/YETUS-379
Commit: 6c003865c4a7309b59f477c5c593983b93f430cf
Parents: 2599d9b
Author: Allen Wittenauer <aw@apache.org>
Authored: Wed Apr 27 21:29:21 2016 -0700
Committer: Kengo Seki <sekikn@apache.org>
Committed: Sun May 1 02:29:55 2016 +0900

----------------------------------------------------------------------
 precommit/test-patch-docker/Dockerfile | 61 ++++++++++++++++++++---------
 1 file changed, 43 insertions(+), 18 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/yetus/blob/6c003865/precommit/test-patch-docker/Dockerfile
----------------------------------------------------------------------
diff --git a/precommit/test-patch-docker/Dockerfile b/precommit/test-patch-docker/Dockerfile
index 08eddf4..5c007cd 100644
--- a/precommit/test-patch-docker/Dockerfile
+++ b/precommit/test-patch-docker/Dockerfile
@@ -19,17 +19,34 @@ FROM ubuntu:trusty
 
 WORKDIR /root
 
+ENV DEBIAN_FRONTEND noninteractive
+ENV DEBCONF_TERSE true
+
 ######
 # Install common dependencies from packages
 ######
-RUN apt-get update && apt-get install --no-install-recommends -y \
-    git curl ant make maven \
-    cmake gcc g++ pkg-config \
-    build-essential libtool \
-    autoconf automake \
-    python python2.7 python-pip \
+RUN apt-get -q update && apt-get -q install --no-install-recommends -y \
+    ant \
+    autoconf \
+    automake \
+    build-essential \
+    bzip2 \
+    cmake \
+    curl \
+    g++ \
+    gcc \
+    git \
+    gnupg-agent \
+    make \
+    maven \
+    libperl-critic-perl \
+    libtool \
     openjdk-7-jdk \
-    libperl-critic-perl
+    pinentry-curses \
+    pkg-config \
+    python \
+    python2.7 \
+    python-pip
 
 # Fixing the Apache commons / Maven dependency problem under Ubuntu:
 # See http://wiki.apache.org/commons/VfsProblems
@@ -44,24 +61,27 @@ RUN pip install pylint
 # Oracle Java
 #######
 
-RUN apt-get install -y software-properties-common
-RUN add-apt-repository -y ppa:webupd8team/java
-RUN apt-get update
+RUN echo "dot_style = mega" > "/root/.wgetrc"
+RUN echo "quiet = on" >> "/root/.wgetrc"
 
+RUN apt-get -q install -y software-properties-common
+RUN add-apt-repository -y ppa:webupd8team/java
+RUN apt-get -q update
 
 # Auto-accept the Oracle JDK license
 RUN echo oracle-java7-installer shared/accepted-oracle-license-v1-1 select true | sudo /usr/bin/debconf-set-selections
-RUN apt-get install -y oracle-java7-installer
+RUN apt-get -q install -y oracle-java7-installer
 
 # Auto-accept the Oracle JDK license
 RUN echo oracle-java8-installer shared/accepted-oracle-license-v1-1 select true | sudo /usr/bin/debconf-set-selections
-RUN apt-get install -y oracle-java8-installer
+RUN apt-get -q install -y oracle-java8-installer
 
 ######
 # Install findbugs
 ######
 RUN mkdir -p /opt/findbugs && \
-    curl -L https://sourceforge.net/projects/findbugs/files/findbugs/3.0.1/findbugs-noUpdateChecks-3.0.1.tar.gz/download
\
+    curl -L -s -S \
+         https://sourceforge.net/projects/findbugs/files/findbugs/3.0.1/findbugs-noUpdateChecks-3.0.1.tar.gz/download
\
          -o /opt/findbugs.tar.gz && \
     tar xzf /opt/findbugs.tar.gz --strip-components 1 -C /opt/findbugs
 ENV FINDBUGS_HOME /opt/findbugs
@@ -69,14 +89,19 @@ ENV FINDBUGS_HOME /opt/findbugs
 ####
 # Install shellcheck
 ####
-RUN apt-get install -y cabal-install
-RUN cabal update && cabal install shellcheck --global
+RUN apt-get -q install -y cabal-install
+RUN mkdir /root/.cabal
+RUN echo "remote-repo: hackage.fpcomplete.com:http://hackage.fpcomplete.com/" >> /root/.cabal/config
+#RUN echo "remote-repo: hackage.haskell.org:http://hackage.haskell.org/" > /root/.cabal/config
+RUN echo "remote-repo-cache: /root/.cabal/packages" >> /root/.cabal/config
+RUN cabal update
+RUN cabal install shellcheck --global
 
 ####
 # Install ruby
 ###
 RUN echo 'gem: --no-rdoc --no-ri' >> /root/.gemrc
-RUN apt-get install -y ruby2.0
+RUN apt-get -q install -y ruby2.0
 #
 # on trusty, the above installs ruby2.0 and ruby (1.9.3) exes
 # but update-alternatives is broken, so we need to do some work
@@ -103,8 +128,8 @@ RUN gem install ruby-lint
 # Install bats
 ####
 RUN add-apt-repository -y ppa:duggan/bats
-RUN apt-get update
-RUN apt-get install -y bats
+RUN apt-get -q update
+RUN apt-get -q install -y bats
 
 ###
 # Set the locale


Mime
View raw message