ace-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bram de Kruijff (JIRA)" <>
Subject [jira] [Commented] (ACE-513) Improve workspace API
Date Fri, 20 Mar 2015 10:29:38 GMT


Bram de Kruijff commented on ACE-513:

Sounds reasonable as that would constitute a major bump.. 

> Improve workspace API
> ---------------------
>                 Key: ACE-513
>                 URL:
>             Project: ACE
>          Issue Type: Improvement
>          Components: Client Repository
>    Affects Versions: 2.0.1
>            Reporter: J.W. Janssen
> The current workspace API has a couple of drawbacks that makes it less efficient when
used in scripts. For example, the create methods ({{c*}}) do not all return the created repository
object, needing a lookup if you want to do other stuff with that repository object after creation.
> A list of proposed changes:
> * let the create methods return the created object;
> * the {{da}} method should accept an {{ArtifactObject}} instead of an {{RepositoryObject}}
(conform the other delete methods);
> * {{lr}} and {{lrp}} both do the same thing: list resource processors. Remove {{lr}}
in favour of {{lrp}};
> * expose the {{createArtifact}}, {{createFeature}}, etc from {{WorkspaceImpl}} as this
makes it easier to read in scripts (the shorthand versions are useful when working directly
in gogo shell).
> Any thoughts, remarks?

This message was sent by Atlassian JIRA

View raw message