ace-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Toni Menzel (JIRA)" <>
Subject [jira] Assigned: (ACE-94) Build requires maven version greater then 2.0.11 but this is not declared
Date Thu, 14 Oct 2010 14:36:35 GMT


Toni Menzel reassigned ACE-94:

    Assignee: Toni Menzel

> Build requires maven version greater then  2.0.11 but this is not declared
> --------------------------------------------------------------------------
>                 Key: ACE-94
>                 URL:
>             Project: Ace
>          Issue Type: Improvement
>          Components: Maven Build
>         Environment: Apache Maven 2.0.11 (r909250; 2010-02-12 06:55:50+0100)
> Java version: 1.6.0_21
> Java home: C:\Program Files (x86)\Java\jdk1.6.0_21\jre
> Default locale: nl_NL, platform encoding: Cp1252
> OS name: "windows 7" version: "6.1" arch: "x86" Family: "windows"
>            Reporter: Bram de Kruijff
>            Assignee: Toni Menzel
>            Priority: Minor
> When you try to build the trunk at r1022542 using Maven 2.0.11 you get the following
non-helpfull error right at the start of the build:
> [INFO] ------------------------------------------------------------------------
> [INFO] Unable to initialise extensions
> Component descriptor role: 'org.apache.maven.wagon.CommandExecutor', implementation:
>  role hint: 'scpexe' has a hint, but there are other implementations that don't
> It seems the build requires a Maven version greater then 2.0.11 (not sure which one exactly)
but this message does not make that clear for the average Jonh Doe. Therefore I suggest adding
a small prerequisites section in the root pom that will make people happy. This will still
cause the build to fail, but this time with the nice and informative message:
> [INFO] ------------------------------------------------------------------------
> [INFO] Unable to build project 'c:\bramk\amdatu\svn\ace-trunk\pom.xml; it requires Maven
version 2.2.1 
> The relevant snippet to add would (assuming 2.2.1) be:
>     <prerequisites>
>         <maven>2.2.1</maven>
>     </prerequisites>

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message