ace-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zoe slattery <>
Subject Re: Running Samples with the Maven Based Build
Date Thu, 07 Oct 2010 12:15:59 GMT
  Hi Angelo
> Judging from the steps you described, it seems you missed the 'retrieve' and 'store'
steps, which I glossed over in the video. Perhaps
is of more help.
Yes - that's exactly right. I ran through it again and can now replicate 
what you did in the video. Thank you so much for your help.

Do you think it's worth updating the getting started instructions as 

1) Remove this  
- unless there is a way to make it work?

2) Update the Web based instructions to:
  (a) specify Chrome or Safari, or at least provide a warning about FF.
  (b) point to the new location of the ace-server and ace-target
  (c) Add a link to your videos.
  (d) Add the explanation of what the web ui (see Marcel's note) is 
doing under the "how does it work' section.

I'd be happy to provide some updated text - but possibly if you are in 
the middle of refactoring the Web UI it's not worth changing the 
instructions just yet. Wdyt?
> On Oct 7, 2010, at 11:08 AM, zoe slattery wrote:
>> On 06/10/2010 21:41, Hiranya Jayathilaka wrote:
>>> On Thu, Oct 7, 2010 at 2:01 AM, Angelo van der Sijpt
>>> <>   wrote:
>>>> Hm, yes, about the drag and drop... It's very well possible this does not
work on Firefox. Last time I checked, Safari and Chrome were both fine. This has something
to do with the dnd plugin we use.
>>> I tried on FF3 and Chrome. No luck so far :(
>> I got further with Chrome. Using Chrome I can:
>> 1) Add artifacts
>> 2) Add a feature and associate artifacts with it using drag and drop
>> 3) Add a distribution and associate features with it
>> 4) Drag and drop the distribution to the gateway....
>> Then nothing. Listing the bundles in the gateway shows no servicebased* bundles.
The frequency of the "[Info ] [   ] Highest remote: null / Highest local: null" makes it very
difficult to do much with the gateway console :-/ I would also have expected that teh servicebased*
files would show up on disk under the gateway somewhere. They don't, but I may be misunderstanding
how this should work :-)
>> Zoe
>>> Thanks,
>>> Hiranya
>>>> Angelo
>>>> On Oct 6, 2010, at 8:45 PM, Hiranya Jayathilaka wrote:
>>>>> Hi Zoe,
>>>>> On Thu, Oct 7, 2010 at 12:06 AM, zoe slattery<>
>>>>>>   On 06/10/2010 18:34, Hiranya Jayathilaka wrote:
>>>>>>> On Wed, Oct 6, 2010 at 3:39 PM, Angelo van der Sijpt
>>>>>>> <>     wrote:
>>>>>>>> Hi,
>>>>>>>> Indeed, I created a set of screencasts quite some time ago.
You can find
>>>>>>>> links to them at
>>>>>>> Thanks for the reference Angelo. Will try this out and get back
if I
>>>>>>> run into any issues.
>>>>>> Hi - I followed through Angelo's 'Simple Deployment' video and got
up to the
>>>>>> point where I could add the three files (servicebased-host.jar etc)
>>>>>> 'Artifacts'. The next step in the video shows creating 'Group's and
>>>>>> associating the artifacts with groups. In the current WebUI the 'Group'
>>>>>> column is replaced with 'Feature'. I was hoping that this was just
a name
>>>>>> change - however, although I could create 'Feature's,  the drag and
>>>>>> which should associate Artifacts with Features does not work for
>>>>> I'm also stuck at this point. I can add any OSGi bundle into the
>>>>> artifact column. I can create new features and distributions in the
>>>>> corresponding columns. But the drag-n-drop across different columns
>>>>> doesn't seem to do anything. Any help would be much appreciated.
>>>>> Thanks,
>>>>> Hiranya
>>>>> Any
>>>>>> suggestions on how to figure out what is not working would be welcome
>>>>>> Zoe
>>>>>>> Thanks,
>>>>>>> Hiranya
>>>>>>>> Angelo
>>>>>>>> On Oct 6, 2010, at 12:05 PM, Toni Menzel wrote:
>>>>>>>>> Hi Zoe,
>>>>>>>>> glad to see you + aries people here on ace. ;)
>>>>>>>>> The log message "Highest remote: null / Highest local:
null" was also
>>>>>>>>> a little confusing to me, but it just says, that there
is nothing to
>>>>>>>>> be deployed on the managementagent (old speak: gateway)
>>>>>>>>> About: "The WebUI is there but looks a little odd"
>>>>>>>>> Its a rush GWT port of a commercial UI that has not been
open sourced
>>>>>>>>> by luminis. Currently, Marcel is doing a Vaadlin Version
instead -
>>>>>>>>> heard its much more straightforward to develop such a
ui than raw GWT.
>>>>>>>>> So, better we'll wait for him here. But i agree the current
webUI is
>>>>>>>>> not the best thing since sliced bread.
>>>>>>>>> But it works, i believe there was a screencast on how
to use it by
>>>>>>>>> Angelo ? Not sure. If not we should make one. Otherwise
its quite hard
>>>>>>>>> to get started.
>>>>>>>>> As a quick hint: you need to add bundles the repository
by copying
>>>>>>>>> them to the upload folder (not sure, its called repository
i guess in
>>>>>>>>> the server folder). They should appear on the left column
in the ui.
>>>>>>>>> Also, when running one or more gateways, they should
appear in the UI,
>>>>>>>>> too.
>>>>>>>>> Now you can bring the "two" together by wiring them:
create a group,
>>>>>>>>> drag the artifact (left) on the group, and so on. So
its drag an drop
>>>>>>>>> based. Coloring indicate "wired" pieces.
>>>>>>>>> Bottomline:
>>>>>>>>> Your builds are fine, just the UI needs assistance and/or
a replacement.
>>>>>>>>> Toni
>>>>>>>>> On Wed, Oct 6, 2010 at 11:31 AM, zoe slattery<>
>>>>>>>>>   wrote:
>>>>>>>>>>   On 05/10/2010 22:59, Hiranya Jayathilaka wrote:
>>>>>>>>>>> Hi Devs,
>>>>>>>>>>> As I understand the two main tutorials available
on the website
>>>>>>>>>>> (Getting started with file based server, Getting
started with Web UI
>>>>>>>>>>> server) deal with the legacy module in the Ace
trunk. So I guess I
>>>>>>>>>>> have to build the legacy module using Ant to
follow these articles. Am
>>>>>>>>>>> I correct? Are there any similar documents for
the Maven based build?
>>>>>>>>>>> Thanks
>>>>>>>>>> I have exactly the same problem. I followed the build
instructions for
>>>>>>>>>> the
>>>>>>>>>> maven build, got the server running and the gateway
(albeit with a
>>>>>>>>>> distracting info message every second(?) "Highest
remote: null /
>>>>>>>>>> Highest
>>>>>>>>>> local: null") - did not get any further than this
so far. The WebUI is
>>>>>>>>>> there
>>>>>>>>>> but looks a little odd - I'd like to get the command
line instructions
>>>>>>>>>> working, any pointers would be much appreciated.
>>>>>>>>>> Zoė
>>>>>>>>> --
>>>>>>>>> Toni Menzel ||
>>>>> --
>>>>> Hiranya Jayathilaka
>>>>> Senior Software Engineer;
>>>>> WSO2 Inc.;
>>>>> E-mail:;  Mobile: +94 77 633 3491
>>>>> Blog:

View raw message