airavata-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (Jira)" <>
Subject [jira] [Commented] (AIRAVATA-3294) Gateway PI having issues login in to the gateway using local account and CILogon
Date Tue, 11 Feb 2020 20:02:00 GMT


ASF subversion and git services commented on AIRAVATA-3294:

Commit 0f95e9a74128e54c44331464955a79ba65137d91 in airavata-django-portal's branch refs/heads/develop
from Marcus Christie
[;h=0f95e9a ]

AIRAVATA-3294 Check authenticate result before calling login

If authenticate fails to produce a user, don't try to login in since
that will fail too and produce a spurious error.

> Gateway PI having issues login in to the gateway using local account and CILogon
> --------------------------------------------------------------------------------
>                 Key: AIRAVATA-3294
>                 URL:
>             Project: Airavata
>          Issue Type: Bug
>          Components: Keycloak Authentication
>    Affects Versions: 0.18
>         Environment:
>            Reporter: Eroma
>            Assignee: Marcus Christie
>            Priority: Major
>             Fix For: 0.18
>         Attachments: Screen Shot 2020-02-11 at 1.26.15 PM.png, Screen Shot 2020-02-11
at 1.27.59 PM.png
> 1. Gateway PI created a local account and we added him to all the groups with admin role.
> 2. When he tried to login he was getting Error page (attached) with message "Forbidden
CSRF verification failed"
> 3. Then he tried CILogon and used google and gave his university credential within google.
He was able to login for the first time. 
> 4. Then he created a GRP but the created resource was not in the list in his application
> 5. So we instructed him to refresh his page and still resource wasn't appearing in the
list. SO he tried to login again using CILogon and was getting error "FAILED to process Outh...."

This message was sent by Atlassian Jira

View raw message