ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Onischuk" <aonis...@hortonworks.com>
Subject Review Request 21114: Ganglia Monitor fails to install on SLES 11 SP3
Date Tue, 06 May 2014 14:50:29 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/21114/
-----------------------------------------------------------

Review request for Ambari and Dmytro Sen.


Bugs: AMBARI-5683
    https://issues.apache.org/jira/browse/AMBARI-5683


Repository: ambari


Description
-------

EC2, HDP 2.0 Stack, all services

    
    
    
    domU-12-31-39-09-AE-11:~ # ambari-server --version
    1.5.0.105
    domU-12-31-39-09-AE-11:~ # ambari-server --hash
    4275c3c742ca045febe51210e8855056786526fb
    
    
    
    
    stderr:   /var/lib/ambari-agent/data/errors-3.txt
    
    2014-03-25 23:19:13,861 - Error while executing command 'install':
    Traceback (most recent call last):
      File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 95, in execute
        method(env)
      File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/services/GANGLIA/package/scripts/ganglia_monitor.py",
line 32, in install
        self.install_packages(env)
      File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 151, in install_packages
        Package(name)
      File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 148,
in __init__
        self.env.run()
      File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line
149, in run
        self.run_action(resource, action)
      File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line
115, in run_action
        provider_action()
      File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py",
line 40, in action_install
        self.install_package(package_name)
      File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/zypper.py",
line 36, in install_package
        shell.checked_call(cmd)
      File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 35,
in checked_call
        return _call(command, logoutput, True, cwd, env, preexec_fn, user, wait_for_finish,
timeout)
      File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 90,
in _call
        raise Fail(err_msg)
    Fail: Execution of '/usr/bin/zypper --quiet install --auto-agree-with-licenses --no-confirm
apache2-mod_php5' returned 104. Package 'apache2-mod_php5' not found.
    
    stdout:   /var/lib/ambari-agent/data/output-3.txt
    
    2014-03-25 23:18:52,044 - Group['hadoop'] {}
    2014-03-25 23:18:52,046 - Modifying group hadoop
    2014-03-25 23:18:52,122 - Group['users'] {}
    2014-03-25 23:18:52,122 - Modifying group users
    2014-03-25 23:18:52,278 - Group['users'] {}
    2014-03-25 23:18:52,278 - Modifying group users
    2014-03-25 23:18:52,340 - User['ambari-qa'] {'gid': 'hadoop', 'groups': [u'users']}
    2014-03-25 23:18:52,341 - Modifying user ambari-qa
    2014-03-25 23:18:52,549 - User['tez'] {'gid': 'hadoop', 'groups': [u'users']}
    2014-03-25 23:18:52,549 - Modifying user tez
    2014-03-25 23:18:52,639 - File['/tmp/changeUid.sh'] {'content': StaticFile('changeToSecureUid.sh'),
'mode': 0555}
    2014-03-25 23:18:52,640 - Execute['/tmp/changeUid.sh ambari-qa /tmp/hadoop-ambari-qa,/tmp/hsperfdata_ambari-qa,/home/ambari-qa,/tmp/ambari-qa,/tmp/sqoop-ambari-qa
2>/dev/null'] {'not_if': 'test $(id -u ambari-qa) -gt 1000'}
    2014-03-25 23:18:52,698 - Skipping Execute['/tmp/changeUid.sh ambari-qa /tmp/hadoop-ambari-qa,/tmp/hsperfdata_ambari-qa,/home/ambari-qa,/tmp/ambari-qa,/tmp/sqoop-ambari-qa
2>/dev/null'] due to not_if
    2014-03-25 23:18:52,698 - User['hbase'] {'gid': 'hadoop', 'groups': [u'hadoop']}
    2014-03-25 23:18:52,699 - Modifying user hbase
    2014-03-25 23:18:52,782 - File['/tmp/changeUid.sh'] {'content': StaticFile('changeToSecureUid.sh'),
'mode': 0555}
    2014-03-25 23:18:52,783 - Execute['/tmp/changeUid.sh hbase /home/hbase,/tmp/hbase,/usr/bin/hbase,/var/log/hbase,/hadoop/hbase
2>/dev/null'] {'not_if': 'test $(id -u hbase) -gt 1000'}
    2014-03-25 23:18:52,836 - Skipping Execute['/tmp/changeUid.sh hbase /home/hbase,/tmp/hbase,/usr/bin/hbase,/var/log/hbase,/hadoop/hbase
2>/dev/null'] due to not_if
    2014-03-25 23:18:52,836 - Group['nagios'] {}
    2014-03-25 23:18:52,837 - Modifying group nagios
    2014-03-25 23:18:52,891 - User['nagios'] {'gid': 'nagios'}
    2014-03-25 23:18:52,891 - Modifying user nagios
    2014-03-25 23:18:52,953 - User['oozie'] {'gid': 'hadoop'}
    2014-03-25 23:18:52,954 - Modifying user oozie
    2014-03-25 23:18:53,020 - User['hcat'] {'gid': 'hadoop'}
    2014-03-25 23:18:53,020 - Modifying user hcat
    2014-03-25 23:18:53,090 - User['hcat'] {'gid': 'hadoop'}
    2014-03-25 23:18:53,091 - Modifying user hcat
    2014-03-25 23:18:53,159 - User['hive'] {'gid': 'hadoop'}
    2014-03-25 23:18:53,160 - Modifying user hive
    2014-03-25 23:18:53,230 - User['yarn'] {'gid': 'hadoop'}
    2014-03-25 23:18:53,231 - Modifying user yarn
    2014-03-25 23:18:53,304 - Group['nobody'] {}
    2014-03-25 23:18:53,305 - Modifying group nobody
    2014-03-25 23:18:53,366 - Group['nobody'] {}
    2014-03-25 23:18:53,366 - Modifying group nobody
    2014-03-25 23:18:53,424 - User['nobody'] {'gid': 'hadoop', 'groups': [u'nobody']}
    2014-03-25 23:18:53,425 - Modifying user nobody
    2014-03-25 23:18:53,523 - User['nobody'] {'gid': 'hadoop', 'groups': [u'nobody']}
    2014-03-25 23:18:53,524 - Modifying user nobody
    2014-03-25 23:18:53,614 - User['hdfs'] {'gid': 'hadoop', 'groups': [u'hadoop']}
    2014-03-25 23:18:53,615 - Modifying user hdfs
    2014-03-25 23:18:53,691 - User['mapred'] {'gid': 'hadoop', 'groups': [u'hadoop']}
    2014-03-25 23:18:53,692 - Modifying user mapred
    2014-03-25 23:18:53,772 - User['zookeeper'] {'gid': 'hadoop'}
    2014-03-25 23:18:53,776 - Modifying user zookeeper
    2014-03-25 23:18:53,856 - Package['unzip'] {}
    2014-03-25 23:18:53,933 - Skipping installing existent package unzip
    2014-03-25 23:18:53,934 - Package['net-snmp'] {}
    2014-03-25 23:18:53,998 - Skipping installing existent package net-snmp
    2014-03-25 23:18:54,134 - Repository['HDP-2.0'] {'action': ['create'], 'mirror_list':
None, 'base_url': 'http://public-repo-1.hortonworks.com/HDP/suse11/2.x/updates/2.0.10.0',
'repo_file_name': 'HDP'}
    2014-03-25 23:18:54,142 - File['/etc/zypp/repos.d/HDP.repo'] {'content': InlineTemplate(...)}
    2014-03-25 23:18:54,143 - Writing File['/etc/zypp/repos.d/HDP.repo'] because contents
don't match
    2014-03-25 23:18:54,143 - Package['libganglia-3.5.0-99'] {}
    2014-03-25 23:18:54,216 - Installing package libganglia-3.5.0-99 ('/usr/bin/zypper --quiet
install --auto-agree-with-licenses --no-confirm libganglia-3.5.0-99')
    2014-03-25 23:18:55,334 - Package['ganglia-devel-3.5.0-99'] {}
    2014-03-25 23:18:55,399 - Installing package ganglia-devel-3.5.0-99 ('/usr/bin/zypper
--quiet install --auto-agree-with-licenses --no-confirm ganglia-devel-3.5.0-99')
    2014-03-25 23:19:02,103 - Package['ganglia-gmetad-3.5.0-99'] {}
    2014-03-25 23:19:02,183 - Installing package ganglia-gmetad-3.5.0-99 ('/usr/bin/zypper
--quiet install --auto-agree-with-licenses --no-confirm ganglia-gmetad-3.5.0-99')
    2014-03-25 23:19:05,999 - Package['ganglia-web-3.5.7-99.noarch'] {}
    2014-03-25 23:19:06,062 - Installing package ganglia-web-3.5.7-99.noarch ('/usr/bin/zypper
--quiet install --auto-agree-with-licenses --no-confirm ganglia-web-3.5.7-99.noarch')
    2014-03-25 23:19:08,890 - Package['python-rrdtool.x86_64'] {}
    2014-03-25 23:19:09,016 - Installing package python-rrdtool.x86_64 ('/usr/bin/zypper --quiet
install --auto-agree-with-licenses --no-confirm python-rrdtool.x86_64')
    2014-03-25 23:19:10,472 - Package['ganglia-gmond-3.5.0-99'] {}
    2014-03-25 23:19:10,550 - Installing package ganglia-gmond-3.5.0-99 ('/usr/bin/zypper
--quiet install --auto-agree-with-licenses --no-confirm ganglia-gmond-3.5.0-99')
    2014-03-25 23:19:11,808 - Package['ganglia-gmond-modules-python-3.5.0-99'] {}
    2014-03-25 23:19:11,875 - Installing package ganglia-gmond-modules-python-3.5.0-99 ('/usr/bin/zypper
--quiet install --auto-agree-with-licenses --no-confirm ganglia-gmond-modules-python-3.5.0-99')
    2014-03-25 23:19:13,077 - Package['apache2'] {}
    2014-03-25 23:19:13,147 - Skipping installing existent package apache2
    2014-03-25 23:19:13,148 - Package['apache2-mod_php5'] {}
    2014-03-25 23:19:13,215 - Installing package apache2-mod_php5 ('/usr/bin/zypper --quiet
install --auto-agree-with-licenses --no-confirm apache2-mod_php5')
    2014-03-25 23:19:13,861 - Error while executing command 'install':
    Traceback (most recent call last):
      File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 95, in execute
        method(env)
      File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/services/GANGLIA/package/scripts/ganglia_monitor.py",
line 32, in install
        self.install_packages(env)
      File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 151, in install_packages
        Package(name)
      File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 148,
in __init__
        self.env.run()
      File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line
149, in run
        self.run_action(resource, action)
      File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line
115, in run_action
        provider_action()
      File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py",
line 40, in action_install
        self.install_package(package_name)
      File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/zypper.py",
line 36, in install_package
        shell.checked_call(cmd)
      File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 35,
in checked_call
        return _call(command, logoutput, True, cwd, env, preexec_fn, user, wait_for_finish,
timeout)
      File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 90,
in _call
        raise Fail(err_msg)
    Fail: Execution of '/usr/bin/zypper --quiet install --auto-agree-with-licenses --no-confirm
apache2-mod_php5' returned 104. Package 'apache2-mod_php5' not found.
    


Diffs
-----

  ambari-server/src/main/resources/stacks/HDP/1.3.2/services/GANGLIA/metainfo.xml b1e37a6

  ambari-server/src/main/resources/stacks/HDP/1.3.2/services/NAGIOS/metainfo.xml 398e6e9 
  ambari-server/src/main/resources/stacks/HDP/2.0.6/services/GANGLIA/metainfo.xml f36a7b7

  ambari-server/src/main/resources/stacks/HDP/2.0.6/services/NAGIOS/metainfo.xml 62b7372 

Diff: https://reviews.apache.org/r/21114/diff/


Testing
-------


Thanks,

Andrew Onischuk


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message